Connecting Fairphone 4 to a Windows 10 PC via USB

Maybe it’s a rare behaviour, but I’ve got problems at that point. The phone was obviously connected, but won’t show up in the explorer, even after setting the phone to file transfer.
I found this website https://www.thefastcode.com/en-eur/article/how-to-get-your-android-device-to-show-up-in-file-explorer-if-it-isn-t with a solution that worked for me. In the lower part there is a description to change the driver by using the device manager. It is like an update, but only looking in the local area. There ist the option to choose somthing like “MTP USB device” instead of “MTP device”. That did the trick, the phone appeared in the explorer and file transfer is possible. By the way, same happend on my business laptop, but there I don’t have the privileges to fix it. So I think, it’s not a special problem of my computer.

You did make sure that you set the right transfer mode (“Transfer files”) on the FP4, right?
(Section “Is Your Phone Connected As Storage?” in your article)

With recent Android versions, this needs to be set anew every time you connect the phone to a computer (it keeps reverting to “Charge this device” afterwards – unless you change this permanently in developer options which isn’t generally recommended for security reasons).

2 Likes

Yes, I did, otherwise it won’t show up even in the USB Deview, and also it won’t work after changing the driver.
And yes, I do have to change from charge to transfer mode every time I plug off and on the device. But this is the case since years (at least for FP2), so I’m used to change that.