Computer can't see the phone after failed install

I tried to install Ubuntu touch through UBports installer, it downloaded some files, then it downloaded some more files, it restarted, there was an error, after that, the computer can’t see the phone again, and I can only go to fastboot. For some time, I was able to go to Recovery mode as well, but now I can only reach fastboot, where I can see my model, and that the bootloader is unlocked.

I tried it on Windows as well, originally, I was trying to install the phone through a Debian VM.

It’s not possible to copy error messages in the fastboot instaler, but some of the error was, in essence:

fastboot: delete_logical_partition: error deleting logical partition failed
error code 1
deleting system_ext_a

How can I install Ubuntu Touch from this stage? Any help appreciated!

UPDATE The computer does not see the phone anymore. What can I do at this stage?

Why not starting again? Is Ubuntu not installed using fastbbot? Else why not install FPOS again and after that start agaun with Ubuntu?

No, nothing else boots, except Fastboot. Not even Recovery at this point. Only Fastboot Mode can be booted at this point, at which state, the phone is not visible by the computer.

So fastboot devices does not work nor the fastboot script to reinstall FPOS?

Yes, exactly. fastboot devices gives empty list. The device is not even visible in Device Manager, under usb-buses.

Thats normal as long as only in fastboot mode.

Did you use fastboot before, so are you sure cable is working with fastboot and all bootloader driver ate upnto date and adb/fastboot on the PC as needee?
If yes, I habe no further ideas, isnt there an Ubuntu Forum, Telegram Channel or something to ask for help?

1 Like

Yes, it used to work, that’s how I destroyed the original OS.

Well, I also asked this on UBports Forum, but they also couldn’t give solution yet: Computer can't see the phone after failed install | UBports Forum

The people at UBports say that most likely the USB port went wrong. I think this might be true. I tried with several USB cables, and with different OSs. And sometimes the computer sees the phone, but this happened only once, when fastboot devices was able to list the phone, and one another time when Windows wrote something like “USB device can’t be recognized.”

Hardware or Software?

Most likely hardware. Not sure.

Well, I guess the Ubuntu folks might have already suggested this, but anyway: You know you can replace the USB port in your FP4 easily? The spare part is available in the Fairphone shop.

You can also first try with a thin metal pin or needle – remove the battery first – if dust and tiny hairs have accumulated inside your FP4’s USB port (in some cases these eventually form a tiny “carpet”). Now if your FP4 is relatively new this is unlikely though.

1 Like

Thanks, but to be honest, I don’t think that really is the USB port that is faulty.
The installation process was interrupted, so most likely, some portion of the boot sector was overwritten by bad bits, this seems like a much more likely scenario. But I don’t know what to do if this is the case.

Do you have fairphoneangel near you?

You may be right with this, but an Angel might possibly help to double check this by exchanging the USB port or by providing a computer+cable approved to work with flashing using fastboot mode…

I don’t have a Fairphone near me.
Do you think it is possible to rewrite the boot sector, if fastboot is not working properly anymore?

I doubt you can repair it if Fastboot really falls to work properly. What I meant is that this would have to be assured first…

1 Like