Charging the FP2 / cable problems

I’ve tried the FP2 battery reset as described in that topic: took battery out, let it cool for ± 1 hour, then put it back in and plugged it into socket. Didn’t work. Still stuck in loop of booting -> battery going empty -> booting -> …

I’m kind of afraid of disassembling this myself. Don’t have the necessary tools for that.

Did you turn it on right away, or did you first charge it until the LED turned green?
Btw: Did the LED turn on at all (red blinking, or red)?

For disassembling: You only need a small screw driver, the display comes off without any tools.
Have a look at this:

As soon as I plug it in, it vibrates and then it automatically tries to boot up (without me pushing any button). That booting screen lasts for about 20 seconds, then the screen turns black. Right after that, the red LED stays on for about 3 seconds, followed by continuously blinking red LED for about 30 seconds, followed by another automatic booting attempt. Again, without me pushing any button.

Red blinking is a sign that the battery is deep discharged.
The vibration and Fairphone logo appearing is part of the charging animation when the phons is off.

Maybe you can try again the reset (I heard in some cases it needed two or three attempts), and after putting the battery back in, only plug in the cable and leave the phone for a while (at least an hour; don’t turn it on, and check the LED again if the light turned steady). Hopefully it will start charging again then.

If both, reseting battery and trying to reassemble the bottom module does not help, I would call support and ask for help (and tell them that you already tried to solve the issue).

I took the battery out again and letting it cool until tonight.

I can’t even get past the first step in disassembling the phone. I unlocked the two blue safeties on the bottom, but I’m unable to detach the screen from the modules. The video makes it seem easy, as if it slides open. But not even using a little force does the trick for me. I’m afraid to make things even worse if I somehow break the screen or the locking mechanism.

(Thank you for your help so far!)

Many people said that taking off the screen for the first time was a bit harder, maybe this link can be of help:

Don’t worry, the phone was built to be taken apart, that’s why you don’t even need tools for getting off the screen. However, since it also is the very first modular phone on the market, it may have some rough edges, which is, that some people reported some problems could be fixed by reassembling certain parts. It might be the downside of this revolutionary design, that in some cases contacts could get lose.
Anyhow, I hope you can solve your problem by resetting the battery already. Good luck!

1 Like

Ok so I found a colleague with a FP2, and I put her battery in my device. Then my device booted up just fine. So I can assume it’s not a problem with the USB module?

What I understood was that you couldn’t charge your battery, so I don’t see the connection just from this.

What I would check:

  • Can you charge your colleagues battery in your phone? (If yes, your bottom module works)

  • More importantly, can you charge your battery in your colleague’s phone? (If no, the battery might have an issue; If yes, charge it for a while until it is not deep discharged anymore, and try it again in your phone).

2 Likes

Hmm … I’m currently charging my battery in her device, and it seems to be working (so far). Would this then mean that there is something wrong with my bottom module?

Possible. If you can charge your colleague’s battery in your phone, probably not, though then it is getting more complicated, what the root cause was. This could be, for example, that you use different chargers (with more or less Amperes); I could imagine that for kicking off a deep discharged battery you may need a stronger charger. But this is just speculation!

Good that it seems your battery charges in her phone. If possible keep it in there for at least an hour; or at least until the charging LED turns yellow, so you have enough power in the battery to boot up your own phone with your own battery. I would expect you can then charge it again in your phone - given that the bottom module works.

Ok, yes, it is charging steadily. The red LED stays on, without flickering. And it hasn’t tried to automatically boot up anymore.

Thank you for all the help so far! Is it OK if I report what happens in an hour or so? I’ll leave it charging like this until it is fully charged. (Though, weird thing: the charging animation doesn’t show percentage. On my device, it tells me what % the battery is charged at at that moment. Now I just see the animation on the battery, but no %)

Please do so! I am very curious to see how it turns out. Sounds good so far!

The percentage and battery animation has slightly changed over the different software versions, I think in later ones the percentage has been forgotten, or simply removed. Btw: This could also be the reason why it charges in one device and not in the other, since some of the updates should have introduced improvements regarding sensibility to different chargers.

I’m now trying to charge her battery in my phone, but it’s unclear whether or not it’s working. The battery animation shows it’s at 74%, but it has not increased over the past 3-5 minutes. Also, when the animation disappears, I see no red LED or anything. Only when I first plugged it in, the LED irregularly flickered for about 5 seconds (as in: not a steady flicker, but LED for 1 sec, then 2 seconds nothing, then 2 flickers in rapid succession, then nothing, and then another flicker, and now no LED whatsoever)

Interesting observation.
It could be related to the charger: Have you earlier used the same charger without problems?
It could be th bottom module as well: If it isn’t properly connected (having a loose contact) to the mainboard, I would expect such a behavior as you described.

Ok, no, her battery in my device is not charging. In fact, it’s discharging even though the charging animation is being displayed. So I tried to boot up my device (with her battery in it), and now it’s “optimizing” my apps, which it also did when I tried putting her battery in my device earlier (and I completed the optimization then, so it’s weird that it has to optimize all over again, isn’t it?)

1 Like

Yes, the optimization is a sign that there could be a problem with the connection between modules, as I have read a couple of times that this happens after people changed modules.

In this case I would recommend again to try disassembling the bottom module, maybe cleaning the contact pins, and putting it together again. Hopefully this will solve the problem.

What software version do you have installed on your phone? (You can check that by going to All Apps --> Updater)

Hello,

what are you using to charge ? A charger or the USB-port of a
PC/laptop/whatever (something which could also establish a data
connection) ?

With my FP2 I have seen this “rolling reset” behaviour, when trying to
charge on a PC/Laptop USB port. Fortunately it disappeared for me with
the latest firmware update 1.5.1. (Same cable, same laptop, same USB-port)

Regards

Martin

P.S.:
If you want to get the display of, you need (at least at the first time)
quite some pressure on the pushing. I only tried that, after one of the
videos clearly showed me the correct direction to get it of. (I had only
been curious, so I tried several times - at first all in vain)

Hey, me again, finally able to post another message.

So, the problem is still there. It still won’t charge.

I managed to disconnect the bottom module, but didn’t really know what to look for. I blew on it a bit, put it back together as neatly as possible. But … no luck. Still won’t charge.

Yesterday I had high hopes, for a bit. For the first time in three days, the little lightening bolt appeared on my screen when I connected the phone to the socket. So, I assumed it was charging. But when I checked the “Battery” settings, it explicitly said “not charging”. So, the phone was telling me both that it was charging and not charging, at the same time. I’ve not seen the lightening bolt since.

Right now, it"s again deep-discharged. When I plug it in, the red LED blinks a few times, then the booting screen appears, followed by the charging-battery-animation. This animation lasts for about 2 minutes, then it tries to automatically boot up again and the phone goes back to deep-discharged with red LED blinking.

I’m not sure what my options are here. Does it sound like I’ll have to buy a replacement for the bottom module? I’d prefer not to be buying spare parts on the hopes that it’ll fix it. It’d be a bad surprise if replacing the bottom module doesn’t fix the problem.

(Last note: I managed to update to 1.5.1. using the battery of a colleague, but it didn’t fix the problem)

What charger are you using? I didn’t see if you wrote that already in your previous posts…

The same charger I’ve been using for months now. A USB cable plugged into a 5V / 1.0A power supply.