English

Charging the FP2 / cable problems

@Colley, thanks for the advice - mine has been pretty consistent about not charging away from a computer, and from the start. However, I bought a data cable and that seems to do the job. However, if I try to do anything on my phone while charging with the data cable, the phone crashes and I have to remove the battery and restart it. Again, it behaves consistently badly in this way - but at least I know and will remember to unplug before doing anything. It works fine while plugged into any computer via a non-data cable and doesn’t crash.

Thanks all for the advice.

Sorry, cannot reproduce your error. Have you tried different cables?

i have more or lesss every problem there could be with charging:

  • the fp2 keeps going out of standby by itself, sometimes it discharges, sometimes it charges
  • the fp2 does only accept certain cables and certain chargers
  • the fp2 is unusable while charging. because it doesnt react to display touches
  • the fp2 is unusable while charging, because the display goes lunatic per touch
  • the fp2 is unchargeable after it reached 15%. i have to compeltely shut down the phone and charge it (sometimes, it statrted up by itself after charging)
  • sometimes i believe, the charge-state isnt honest. eg when reading, using the same app: one time i can read for hours, another time i have no force left after reading for some minutes.

i really would like to know, why it is like that and what i can do?
i really wanted the fp2, i didnt send it back, but as sad as it is: after experiencing, more or less approx. 5 bugs from the beginning, i cannot recommend it.

I found out that I can’t turn on my FP2 while plugged in. Only the charging animation appears. To turn on the FP2, you have to pull out your charging cable.

Just a short update here, we have broaden the charging range for the Fairphone 2 with the software update 1.2.8 (now available to everybody).

I have also updated the poll with the software version and the “touch screen usable during charge” so that if anybody still experiences issue, you can post an updated response.
Thanks again!

hey wolfie,

For the first issues, I would like to know if the software update helped you.
For the last two ones, have you tried to kickstart the battery?
If your issues still happen, please send a request to support (and PM me your ticket number) with screenshots of the battery report (both regular and detailed, when you click on the battery graph).

tofra,

same thing as with wolfie, could you please report after updating to 1.2.8?

I am so happy, after the update my phone is charging with my old charger. :relieved: :ok_hand:

2 Likes

It works, but you have to press the power button much longer than usual. (I have not tried such a long press before the update.)

I did and all the time, I had to press it longer as well - looks like normal behaviour.

hi borjan,

i tried a battery-kickstart already and it didnt help - but the update did!
magically, it works now to use it, to use every cable, to load it without random startups, i would say: its working flawlessly!
thanx a lot and keep up the good work!
now i am able to recommend it :slight_smile:

2 Likes

Hello,
update to my post.
I found one interesting effect (“old” FW):

When I had my FP2 switched on and connected to the USB port of my laptop, switching from “charging mode” to
to one of MTP || PTP (probably PTP) changed it to "not charging"
Sorry, I don’t have the mode, because when I tried to reproduce I wasn’t able to do so. So this only happened once so far.

Then I tried more systematic on the “rolling reset” issue: (All with the FP2 connected to my Win 10 laptop)

  1. FP2 switched on; connecting to USB
    MTP – charging
    PTP – still charging
    charging – still charging
    MTP – still charging
    Off (while in MTP mode) -> rolling reset

Same ending in PTP
Off (as PTP) -> rolling reset

On my first try with the new FW 1.2.8 it seemed in one case to be more picky. Same cable, same USB port (the USB port of my Fritzbox, because it needs standby current anyway,) Here it seems to barely load while switched on, instead the FP2 got warm (something warmer than body temperature, not hot) This had been better before. (Or it depends on some other factor which I didn’t recognise so far)

Martin

P.S.:
Just to spell it out: I’m happy with my FP2, despite these problems. (Other here say it’s a show stopper)
I didn’t expect it to be perfect. I surely hope that FW updates fix some of the drawbacks.
But I like it nevertheless. I got what I wanted; I wanted that smartphone also as a “political statement” (electronics can be done better); at the same time the decision “feels” correct and I’m partly amazed of how (and how often and for what purposes) I use it.
I had several (smaller) decisions to buy stuff, between the pre-order of my FP2 and now. (no electronic gadgets)
There my “requirement analysis” seemed to have been incomplete and I had been somewhat disappointed. The FP2 was one of the bigger decisions done right from my POV.

1 Like

How long is this longer-than-usual press? Two seconds? Fifteen seconds?

I have tested it now. Usual press to turn it on = 1 second, longer than usual when plugged in = 4 seconds.

That is fine and expected behaviour.

To make things clear:

  • If the phone is off, a short press (1 second) will boot the phone.
  • If the phone is charging, a short press (1 second) will display the charging animation and a long press (3~4 seconds) will boot the phone.
4 Likes

Hi,

I just submitted an issue with my Fairphone 2 and charging. (See ticket #98477)
The battery was completely drained while it was attached to the charger. This happened after the 1.2.8 update.

The battery is completely drained and I can’t start my FP2.
I added a USB current measurement device to check if it’s charging.

It seems that the charger delivers 0.91 A while the phone is completely off.
When it boots to battery charging mode, (with the battery animation) no current is drawn.
Also no LED is on at that moment.

After a while the phone spontaneously boots or just goes back to completely off, with red blinking LED.
After a while the whole process repeats.

Sometimes Android tries to start and wants to optimize applications.
After optimizing 50 apps, it just goes back to the completely off state (with red blinking LED)

The charger, cable and FP2 used to work OK.

best regards,
Jelle

I have the exact same problem as @jhaand. I just “charged” my phone the entire night and it is still completely drained. I did not use any other chargers or did anything differently than I normally would.

I am fairly confident that we can confirm HTC’s TC E250 (5V, 1A) as being problematic with the FP2, at least at low battery charge levels (with both the former and the latest software).

We have a total of three of them in our household and we’ve tested them all (with several different cables, none of which seemed to have made any difference one way or the other), and they all caused unstable charging until the battery went beyond a certain charge level. Beyond a certain level, charging stabilizes, but is still slow (~6 hours to fully charge from ~10%, for all three TC E250s).

The ASUS ADP-188W A (5V, 2A) which came with my TF201 works just fine at any charge level and charges much faster.

My assumption would be that the TC E250 is unable to provide a stable enough current for the FP2 at low charge levels, but I don’t have the necessary equipment to make any measurements. It did manage to charge the phone, but not in a satisfactory way.

Jelle, and Emma,

What happens if you use a more powerful charging facility - such as one delivering 1.5A or 2A?

Please remove the battery for at least 30 minutes and try again to charge the phone with a powerful charger to see if it makes a difference. If possible, let the phone charge completely (and then some more) before booting it.

I do agree with Dunsay in that less powerful charging facilities and not stable enough ones might not work as expected, especially when the battery charge is (very) low.
Jelle, you said your charger+cable were working fine before but did you ever reach such a battery state (depleted)?

i have to correct myself: random reboots happen now more often, eg when starting a call while dialing.
not every cable is accepted, but a big relief, nonetheless.
lets see…

i found the solution in a german thread: for the reboots after starting a call: its the setting 4g preferred