English

Changed rear camera 8 Mp, no connection anymore

Dear community,

I changed the front camera module (8 Mp module) yesterday, and everything worked fine. I took some photos, camera focussed as it should, and I was satisfied.
Now this morning I wanted to scan a QR code, and the system said “can’t connect to camera”. I switched the telephone off and on; now the camera works but only in selfie modus.

How can this be explained?

Thanks a lot for your help,

Eva

The front camera has 2MP original and 5MP with the new module. So what exactly did you change? The back camera has 8MP or 12MP resp.

Hi Icanus, sorry, I confused front & rear. Somehow thinking that the more important camera must be the front one, even if the lens is in the rear.
So it is the REAR camera, 8Mp module. 12 Mp is no more available. I’d have purchased that one…

Did you have a 8MP before or did you replace a 12MP cam?
Anyway, I would suggest to check the connectors and perfect alignment of the camera module again.

1 Like

Thank you for your quick answers! To be honest, I don’t know what I had. Couldn’t find it on the invoice or on any e-mail I still have of that time. But when looking on the FP website, the 12 MP camera looked slightly different (white horizontal stripe between lens and flashlight), so I suppose I always had 8 MP.
Do you think the connections/ alignment might be in disorder now when the camera worked perfectly well yesterday? I find that somehow bizarre, I’d rather have thought it might be a software issue. Will have a look anyway.

Why did you change the camera anyway?

When you are running FPOS on Anroid 9, then indeed it might be Software related as there are some bugs since Android 9. so Plesse try another APP like Open Camera and see if it works.

1 Like

Hi, I changed the camera because the initial one didn’t focus anymore. I could not use my bank app (scanning QR code), scan app etc.
With the new one, it worked fine - for one day.
And now I tried Open Camera (thanks, yvmuell), but I’m again only in Selfie modus.

1 Like

Hello again,
I opened the FP2 again (hate to do so, because my display doesn’t glide effortlessly, as they do in the YouTube videos), screwed the micro-screws of the camera a bit harder (feared to do that initially, because I’m always afraid the screws lose grip and then I cannot open them again), put the telephone together - and the camera worked!
Thanks a lot for the good tips, and I hope now it works for more than 24 hours…

5 Likes