Cellular data connection not working

I have a pre-paid SIM with a 2gb quota for data. This worked perfectly in my previous phone.
But since I transferred this SIM to my FP2, I no longer have any access to data via the cellular network.
Although the cellular data is well turned on, and my provider is mentioned as preferred SIM for cellular data, whenever I try for example to check my mail on the phone, I receive a “no connection” feedback.
If relevant, I only have one SIM card on my phone.
Does anyone have suggestions of settings to verify or action to take?

It could the a problem with the Privacy Impact. Workaround: Re-enable Privacy Impact by unticking the option found at Settings > Sound & Notifications > Privacy Impact.
Also check that you have selected 3G/4G for your pre-paid SIM.
If that’s not solving your problem, please tell which provider you are using.

Thanks for the quick response Lidwien!

The privacy impact was already unticked.

My provider is Mobile Vikings.
I checked on their site as well, and there is a configuration wizard there to set up the internet connection.
Unfortunately the FP2 is not on the list of phones for which they provide instructions for this set up, so I just sent a mail to their support service…

Have a look at the APN settings. I found this: http://wiki.apnchanger.org/Belgium#Mobile_Vikings

Problem solved!!! Thanks a million Irina :relaxed:

1 Like

Here you can find instructions how to set your phone manually to internet. The samsung galaxy s 3 mini has the same android version as far as I know.