Can't stop encryption / How to show Caller ID to others?

I just got my own FP3 this week and every time I call people they see UNKNOWN caller. I found encryption settings in security setting but I can’t turn the encryption off no matter how many times I push the setting. Can someone help me turn the encryption off?

Thank you!

This has nothing to do with encryption at all. Encryption encrypts your data in the phone storage. Combined with a screen lock method this should prevent somebody who steals or finds your phone from accessing your data.

What you are after is a setting for the “Caller ID”.
For me* that’s in the dialer App - three-dot menu in the top right corner - Settings - Calling accounts - (select your SIM card) - Additional settings - Caller ID … Where I could set to hide or show it, or to use the “Network default”, whatever my provider set up for this.

Alternatively, you could ask your provider how to set this with entering a so-called GSM code in the dialer App, or you could try entering the ones given here for yourself …

* I’m not using the stock OS, but the setting should be there somewhere.


Thank you so much:grinning: I found the way with your instructions. Now I won’t scare my contacts when I call them.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.