Can't send SMS (text message) via WiFi calling when airplane mode is on

  • No issue with making or receiving calls.
  • Android 11 (build 8901.4.A.0016.6
  • My usual SMS app is QKSMS, but I’ve also tried Simple SMS Messenger and the default Messages app. QKSMS gives the same error message as I’d get with no reception. Other apps mention airplane mode specifically as the reason why the message can’t be sent.
  • My current provider is ASDA mobile, which uses the Vodafone network.

Any idea what’s going on here? Is this an issue with the Vodafone network, something in android, a limitation in the Fairphone 3 hardware, or an oversight in the design of WiFi calling?


I have no such problem on EE in the UK. I have no mobile network and can only use Wi-Fi

I have aeroplane mode on all the time so have enable Wi-Fi separately, I also use QKSMS

So the only difference is Vodafone ??

Has this only occurred after the 0016 update ??

I only get that when Wi-Fi calling isn’t working.

You can also check Settings > Network and internet > Wi-Fi (you are using) > Wi-Fi data usage (Mine shows QKSMS as having used data)

This is excellent. All signs point to Vodafone. I’m actually planning to switch to Honest Mobile, which uses the THREE network, so we’ll see if that fixes it.

I have no idea. I only just discovered that WiFi calling was possible on Fairphone 3/all the networks.

Mine says “No data used”. Interesting, but I’m not sure what that tells us. “Background data” is enabled, and it has all the permissions. Mmm installed via F-Droid, not Play store. Does that matter?

That was my reason to get a new phone as I have no mobile signal :slight_smile:
No data used confirms the phone agrees with you and as for install I did the same from F-Droid

See if you can borrow another SIM before you make the change.

I also remember I had to find a network signal to enable full working of the Wi-Fi calling etc.

1 Like

Switching from ASDA mobile (Vodafone) to Honest Mobile (THREE) fixed it. It’s possible something was misconfigured by me with ASDA mobile (APN maybe?) and it could have been fixed, but I’ll never know now.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.