Can't receive SMS messages on new Fairphone 3

Two days into using my new Fairphone 3 im am confronted with an issue which I did not have on any of my former 4 smartphones.
While I am able to send messages to different phones I have access to, return messages do not appear in the received list of the FP.
I am using the standard “Messages” app.
The content of the phone (apps and data) was downloaded from a Google backup of the former phone, a Motorola Moto Z Play of 2017.
A hint for what to set or where to look is very much appreciated.

Edit: Same result using the Textra app as standard messenger.

Here are some generic hints for a start …


Did you use an iPhone in between or before the FP3?


No, I have not use an iPhone in my life.
I saw however, that my provider, Telefonica O2, sent a message to install the internet access settings on the FP3. Could it be that they don’t have the FP3 on their list yet? It’s puzzling anyway that I got their message, but none from anybody else.

Have you tried another SMS-App? I had a similar problem with the FP2 back in the days, not with the FP3 though. When I tried the standard messanger years later, it suddenly worked…

PROBLEM SOLVED: Not a Fairphone problem.
After extensive searching I found the reason for the malfunctioning:
I have a contract with O2 which gives me three SIM cards on the same mobile phone number. Only one of them receives SMS messages from O2. Which one that is has to be set on the O2 support website.
Due to format reasons I had to change the SIM card when moving from my old phone to the Fairphone and I forgot to change the delivery settings accordingly.


Dear ben, on the search how to solve my problem with not receiving meassages from iphones on my new fp3 I stolpert over your question: I indeed used an old iphone 4 for some weeks after my fp2 was stolen.

Now with the new fp3 it seems that iphones don’t recognize my phone as NOT an iphone: So whenever someone sends a messages to me, it will be sent as “imessage” and appear on the iphone as “sent” - but I will never receive it. Only when I tell the sender to send it as “sms” I can receive it.

Do you have any idea for a workaround?

Your number is still registered for iMessage. Whenever you stop using an iPhone, remove your number from iMessage:


dear ben, thank you so much for your help! *gladgladglad

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.