Can't receive any calls nor messages

I bought my Fairphone2 two weeks ago (530€, very expensive I think but you do what you gotta do to try make this world a bit better right?). 2 weeks ago means that I’ve never changed anything on it and it has never fallen.
Since yesterday night, I can’t receive any calls nor messages (pretty embarrassing for a phone, isn’t it?)… I can make calls and send SMS though. Rebooting doesn’t change anything, I have signal, and I have only one SIM. I looked up other forum topics that could give me the answer but none of them worked.
I also don’t understand because it happened overnight, it worked fine until now, and I didn’t change anything on the phone that could explain this I think.
Anyone could help me please?

It’s always a good idea to list all the tips you already tried, so we know what not to suggest to you.
Also a little better description about how you fail to receive calls would be nice.
First thing I’d think of would be a permissions issue:

Thanks for your quick answer!

I tried to change the 2G/4G settings (which quite frankly i don’t really understand but put it back the way it was because all i tried didn’t change anything), looked into the apps permissions, uninstalled my antivirus app in case.
To answer your request of how I fail to receive calls, the phone doesn’t ring and the person who calls goes straight up to the voicemail, as if it was turned off.

Just to double check: Did you look into the notification settings too?

Otherwise to rule out a software issue you could also try #dic:safemode.

If it’s not a software issue I’d next look into the SIM card. Have you tried to put your SIM in someone else’s phone and see if you can receive calls there (also try the counter test with their SIM in your FP2)?

1 Like

Yes, I did.

Yes, it works fine on other phones, and it worked before in the FP2 so I don’t think it’s from here.

I haven’t done this but I’m not really keen on doing it, so it would be my last option

You can still #contactsupport.


Also safe mode is not like a reset. Some accounts, settings and widgets might get lost after booting into safe mode, but that shouldn’t take long to set back up.

I have contacted support and am waiting on their answer, thank you for your help!

1 Like

Have you been able to solve this issue? I suffer from the same problem…

I didn’t do anything particular… Apparently it was a bug from my network operator

Thanks, Emma, I suppose I’ll have to take to my network operator too…

All the best for 2019!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.