Can't play Ogg Vorbis properly

Hi there,

I have a bit of an issue that caused me a bit of headache to get my head around.

I can’t play music in the Ogg Vorbis codec properly anymore. This includes both playing via the speaker as well as playing through the headphone-jack.

Weirdly however, it works perfectly fine when playing through a bluetooth receiver (I have a tp-link HA100).
I also found out a couple minutes ago when I was about to record this… it works when using scrcpy to record the screen including audio, but not when recording excluding the audio (i.e. --no-audio). Yeah… this took me a bit to realise, go figure.

I tested 3 different players: Vinyl, Musicolet, and YouTube Music (and oh my god this one is a dumpster fire… clearly noone at Google is using their own product).

As far as I know both Vinyl and YT Music uses the system audio decoder, while Musicolet has an option for either system or its internal one.

The issue happens in all 3, except when setting Musicolet to its internal decoder. So everything points to something being broken in the system decoder.
Oddly, with YT Music I can sometimes get it to play, when I click the same track over and over after it skips, but it’s not consistent. With Vinyl and Musicolet it is always broken.

I got some scrcpy recordings for what it looks like. Vinyl left, Musicolet (system decode) middle, YT music (and oh my god it took me longer then writing this post to record this…) right:
fp3_vorbis_vinyl fp3_vorbis_musicolet fp3_vorbis_ytmusic

Geez YT music is utter utter garbage… it takes literal 2 minutes to even just show the “Device files” category (and that every time I re-open the app) and then another 2 to show all Albums. And then it doesn’t even always add them to the current queue properly. Anyway…

Any idea what’s causing this? I am fairly certain that it worked fine before the upgrade to Android 13, but I wouldn’t vouch for that.

Seeing as it works under some circumstances I don’t see it as an issue with the codec, but obviously it’s having trouble outputting the decoded audio locally as it works both when recording and transmitting via Bluetooth.

mediainfo in case it’s relevant:

$ mediainfo 01.\ Icarus\ -\ Main\ Theme.ogg 
Complete name                            : 01. Icarus - Main Theme.ogg
Format                                   : Ogg
File size                                : 2.76 MiB
Duration                                 : 3 min 41 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 105 kb/s
Album                                    : Deus Ex: Human Revolution (Original Soundtrack)
Part                                     : 1/1
Part/Total                               : 1
Track name                               : Icarus - Main Theme
Track name/Position                      : 01/25
Track name/Total                         : 25
Performer                                : Michael McCann
Composer                                 : Michael McCann
Genre                                    : Soundtrack
Recorded date                            : 2011
Writing application                      : Lavc57.22.100 libvorbis / Lavf57.21.101
ALBUM_ARTIST                             : Michael McCann
SOURCE                                   : original
MTIME                                    : 1511014650
SIZE                                     : 22709449
MD5                                      : 277edd09df1ab959ce4bf66dcf5cd89e
CRC32                                    : 96f9d948
SHA1                                     : bd6f3a28aef0da781bf12e59e1068c92e3277c09
FORMAT                                   : Flac
LENGTH                                   : 221.24
HEIGHT                                   : 1401
WIDTH                                    : 1401
ITEM_IMAGE                               : /t/embedded_imagedvHOCh

ID                                       : 2566407249 (0x98F84451)
Format                                   : Vorbis
Duration                                 : 3 min 41 s
Bit rate mode                            : Variable
Bit rate                                 : 96.0 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 44.1 kHz
Compression mode                         : Lossy
Stream size                              : 2.53 MiB (92%)
Writing library                          : Lavf57.21.101

Also note this is obviously just an example, every Vorbis track I have is showing the same symptom.
I should also note every other file is fine… MP3, Opus, the handful of FLAC files I have on it, all playing with no issues.

Couldn’t find anything on the forum so far, unless I missed it. But I guess that’s also just due to Vorbis not being super popular.

Any help is appreciated, thanks in advance!


With app VLC I have no problem playing the file through the phone speakers and through my hearings aids using bluetooth.


VLC uses its own internal decoder, not Android’s system decoder. So it’s not surprising it works, just like Musicolet does when using its internal decoder.

Thank you for the input however.

1 Like

Hate bumping but… can really noone replicate this in a player utilising the Android system decoder and not an internal one?

Well, looks like that have the same issue. Tried with Vanilla Music and Total Commander. Spotify’s player works, but I guess they use an internal player and not an android component for their player.

It definitely worked just fine before the upgrade to A13.

1 Like

Thanks for the report, yes I do have the feeling it worked before the Upgrade but I honestly couldn’t say for sure because I mostly used Musicolet before the upgrade, while I’m now on Vinyl.

I would assume so as well, if nothing else for the DRM stuff.

Dear All,

I can confirm the problem. It’s not DRM related.

Only VLC is playing ogg-files.

Neither Vanilla nor other players I tried play *.ogg files since the update to Android 13. No problems with other formats (mp3, flac) though.

Couldn’t find any information upstream.

What has happened here?

1 Like

@SoeDib @luciljus one of you happen to be able to confirm that weird behaviour with Bluetooth/Recording I was describing too?

@Tarulia: didn’t test recording, but this bluetooth thing I can confirm. Playing through my JBL Flip 3 definitely works, while the phone on itself skips ogg files after 2 seconds or something.

@luciljus: found on FDroid a thing called “Phonograph Player” that plays my ogg files.

1 Like

Same here: didn’t test recording but playing via Bluetooth works. As soon as I disconnect bt, it stops.

Phonograph plus from Fdroid plays ogg-files flawlessly.

1 Like

That’s odd because Phonograph is the predecessor to Vinyl…

I assume you’re talking about Phonograph Plus then.
I just tested and it shows the same behavior the YouTube Muwic App does, i.e. sometimes it plays and sometimes it doesn’t. It also stops after every track and sometimes just skips through the play queue. So it’s mot fully functional either.

Today I received the Android update from 5 August 2023, but it changed nothing regarding this problem.

As Phonograph plus is buggy and crashes regularly, my only workaround is using VLC, which is not very comfortable as a music player.

Anyway, a Fairphone should play a free format like ogg.

Did anyone report this to support, else it will be difficult to work on it?


Not yet, as I wanted to gauge if this is a “me-issue” or a general one. I didn’t have a lot of time lately to write to them anyways.

I reported but too late for this update.

My comment wasn’t meant as critique, only as update of information (sometimes problems of a major software update disappear with the next point release).

They only give support when I can send a proof of purchase of my phone, which I don’t have anymore. So someone else will have to submit this issue.