Can't install update FP3V.A.0116 on new phone

Are you both located in the Netherlands and using the same mobile network provider? Not sure why or how, but as the updates are rolled out based on the mobile network provider there might be an issue?

1 Like

Have u gotten any updates from support?

I am having the same problem, got my FP4 last week but it does not update. Also reached out to support, but so far they only confirmed that they received my request and will get back to me. I will probably send it back unless there magically is a fix or at least a helpful reply from support in the next few days…

I’m in France and whilst the first part of the installation (before they request a restart) seemed to be fine, but the finishing system update" has been going for 2hrs now without finishing, which doesnt seem right.

I’m using T-Mobile for my mobile network. My internet provider is Fiber Nederland, but I also tried the KPN-network from relaties. The problem occures when the program tries to “optimalise” my phone. After that I get the error. I switched of my anti-virus scan so I don’t think that is the problem.

2 Likes

Just tried to reach support, but “something” went wrong with sending the message to them via the Fairphone app. I have to try later…
Not a great look, Fairphone…:expressionless:

Could someone with that issue please capture a logcat :pray:

  • $ adb shell "logcat -c && logcat > /sdcard/logcat.txt"
  • Start the update and wait for it to fail
  • Press Ctrl+C in the terminal you have adb running
  • $ adb pull /sdcard/logcat.txt

Maybe there is some obvious error in there :thinking:

3 Likes

I’m sorry, but I have no idea what to do with that code you just send. I’m not a programmer.

1 Like

No problem, maybe one of the others with the same problem is already familiar with adb.

But you don’t have to be a programmer to use it, so if you want to “expand your horizon” (and have maybe half an hour of free time), here’s a tutorial how to set it up in case you’re interested :slightly_smiling_face:

3 Likes

Why using a shell and print output to sdcard and then pull to PC and not directly via USB cable without shell to client filesystem?

What’s better to create a shell connection to the device and execute it there?

Because I can’t assume anything about the system the person running that command is using. Who knows if shell redirects work as expected.

I’m just using adb logcat -c && adb logcat > logcat.txt on Linux of course.

1 Like

thx
I’m doing it that way, too
But your thoughts are correct

1 Like

Lol, honestly didn’t expect so many comments here anymore and especially not so many similarities with my situation.

But let’s just update you guys with the latest findings I had:
So bad news is that I haven’t send them a request for help and therefore don’t have any direct info from them. Other bad news is that I’ve spend way too much time solving this issue.
Good news though: I can now install updates.

The way that I fixed it was by flashing the entire operating system again (using adb). I did this while pulling out the SIM and SD card. After a stressful installation (it was the first time for me and not everything completely went as stated in the tutorial) I managed to successfully install a new operating system on my phone. To my frustration it did not install the update with the operating system. However, when trying to install the update again it successfully completed it :partying_face:

Do I recommend this solution? Well… If you’re careful and have the time for it then sure. I would probably first try a restart, pulling out SD and SIM and those kind of things.

The main reason I did it was because I was fed up with the support, wanted a device that’s up to date and still wanted to keep my phone. Fairphone itself made it pretty difficult to contact them (links for contacting were broken, ticket creation failed and finally the mildly aggressive FAQ of them sent me to the adb solution). Luckily the device seems to be working fine now and I can recommend it to people again. I just hope somewhere that there is a better and easier solution to this problem.

I do also have to say btw that yes, I live in NL, yes my phone uses T-Mobile for data and yes we use Fiber for internet. Although it is probably unrelated there is funnily enough some similarity there XD

3 Likes

Also to the one using the Fairphone app for support: I would strongly advise against that. The app seems to be full of bugs in it current state. Use their official web page instead.

Not what anyone wants :frowning:

i took out the sim and sd card and restarted… got the message “update successful”. turned it off, took the battery out for 5mins, put the sim back in and restarted. seems fine. add the sd card, and it is stuck on “loading…”. curious.

Just out of curiosity, since removing the SD card (and SIM) seems to help, did any of you have the SD formatted as internal storage? :thinking:

So is it stuck loading the SD card or is the phone not booting entirely? Does that behaviour continue after a reboot?

4 Likes

I dont recall how the old sd card was formatted (but seems that it was corrupted, so that might have had something to do with it!).

So, without the sim and sd card, the updated finished and reported that it was sucessful.
Put the sim in, everything seemed to work fine.
Put the SD card in, issues. Tried reformatting, no success. Told the phone to forget that SDcard, put a new one in, everything seems to be working again :slight_smile:

Sd, loading the sd card might have been the issue.

3 Likes

Hi, just want to say I’ve been having the same issue as the others. I tried updating the phone with and without the SIM card, but there was no difference, I kept getting the same error. I don’t have an SD card installed either, I haven’t rooted or done anything else to the phone. While updating the phone without the SIM card the first time I tried, I got a popup that said something like “Location cannot be null”. And like I said, otherwise for me, there wasn’t a difference. It went to the optimizing stage and then failed at the end.

3 Likes

Not using any SD card here. Removing SIM also doesn’t make any difference. Although his problem sounds slightly different from the one the rest of us is getting.
As mentioned elsewhere in this thread, for us the update seems to download and install just fine until it stops while optimalising the device. We don’t even get to the restart part of the update…

1 Like

Welp, removing the SIM-card didn’t work and I haven’t got a SD-card for my phone yet. I also don’t want to hack my phone, so I guess I’m stuck now.