Can't install open gapps on 18.10.0 (FP open)

… the procedure described under ( did seem to work in itself. However, my FP2 has now been trying to boot for about an hour or (Fairphone Logo on the screen, and blue circles pulsating from left to right). Surely, that can’t be it? Many thanks for any help …

Which binary image did you use?

Hi, I used the binary linked in the link below, that being [Binary image] Fairphone OS 18.04.1 (Android 6.0)
Does that clarify things? Many thanks …

You started out from Fairphone Open OS, right? If that is that case, data on your data partition may be incompatible with the Fairphone Regular OS system image (which you appear to have used). Switching between the two normally requires wiping the data partition for this reason. In your case, I’d suggest first trying whether the binary image for Fairphone Open OS (Android 6 18.04 or Android 7 18.10) does give you a booting system.

1 Like

Fantastic advice, many thanks, I used the Fairphone Open OS binary for Android 7 and now get a bootable system. Pheew … :grinning:
One bug immediately gets my attention: on pressing the power button and selecting “shut down” the phone restarts. Nevermind.
Next mission: install the latest OpenGapps. I am following the procedure described here (, with no effect: the version of TWRP stays and is not updated to 3.2.3.
Any ideas on that would also be greatly appreciated …

You won’t believe the workaround: Enable the torch function before shutting down.

The first 10 or so posts of this topic have information that can help you get installed from an image file in TWRP itself. After installing, you will need to reboot into TWRP (rather than the normal system) to finish the install (otherwise it reverts).

1 Like

Many thanks again. I had over-read that TWRP needs to be rebooted “in itself”. For others, this means, in TWRP, you select “reboot” and then “recovery”. GREAT STUFF. And now, with all this working again: what is a good way to make a backup under Fairphone Open OS?

I’m not an expert in back ups, and it’s a bit off-topic here, but suggestions (any of which may be a solution)

  • Search the forum for suggestions (not sure whether this has been tackled recently)
  • Manually copy all the files in /data/media (e.g. photos) and use TWRP for the rest - there’s a recent guide here.
  • Look into MyPhoneExplorer (warning: proprietary software), which seems to be a popular choice amongst veteran forum members.

hey were can i find any file of twrp to download! on the official side i cant find it…

TWRP downloads for the FP2 are found here if that’s what you’re asking.

Than you!
now there is a new problem… i tried to install the img via twrp but when i reboot the phone and start it to twrp it has changed nothing…

You have to reboot into TWRP right after updating otherwise the OS will overwrite TWRP again.

Oh thank you! now it goes right! :wink:

1 Like

Goodmorning everyone,
forgive my little self-importance!:blush:
I have a microsd formatted as shared memory.
I downloaded the latest version of TWRP (the image file I mean), and the file with the signature.
I turn off the phone, I access TWRP by pressing the volume up key, I go to “Install”, but I can not find the download folder, even moving between internal archive and microsd: where am I wrong?
Thanks to those who will help me! :slight_smile:

Hey I had this problem too and tried updating twrp by flashing the latest image file, which seems to work but twrp is still in 3.1.1-0. Any idea what I’m doing wrong?

Can you not find the folder, or can you find the folder, but not the file? If the latter, make sure you switch the file browser to show .img files, as it shows zip files by default.


Thank you! This worked.

Thanks a lot for the answer. :slight_smile: So yes, I probably did not explain well, sorry! I meant that with the microsd formatted as internal memory, entering TWRP mode, I could not see either the Download folder nor the DCIM folder, in short, I could not find any of the user folders.
I tried in several ways, I finally formatted the microsd again as external memory, I downloaded the .img file and updated TWRP signature, I logged into TWRP and clicking on “install”, I immediately found all the user folders, and I could update TWRP. At that point, I also managed to install opengapps. Next, I re-formatted the microsd as internal memory, and my FP2 works perfectly! :+1:
I’m left with the initial doubt, if someone more experienced than me, will leave me two lines of explanation, I will thank him very much.
Good evening and apresto! :slight_smile:

Hey guys,
sorry,I might just be too stupid to get it,but I have the same problem as described above: installing twrp 3.2.3-0 seems to work, but after rebooting 3.1.1-0 reappears. And I did first reboot into twrp recovery like advised. The first time everything seems ok and I am able to install the latest OpenGapps pico package. After this install,the phone automatically boots into Fairphone OS. First I thought everything was alright. Then the message “Google Play services for Instant Apps wird wiederholt beendet” kept appearing and some apps like Google Maps don’t work smoothly (i.e. crash).
When shutting down and restarting into twrp, version 3.1.1 was again showing up. Any ideas what I might be doing wrong are appreciated. Thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.