Can't install Apps with F-Droid

I’ve installed f-doird on my FP2 in the hope to explore FOSS apps (the different topics about it in the forum are great, as is the list of apps used by different forum members).
I installed F-Droid from the apk on their website, when I look into the catalog of app and try to install one by “clicking” on it… well… nothing happens.
Am I doing something wrong?
I installed it on an Iconia Tab and it works…
I’ve read in an other thread that privacyimpact made some app misbehave. Could it be it? I can’t seem to find the way to disable it though…


1 Like

Did you allow “Unknown Sources” in Settings > Security?

yes! I did it in order to install f-droid. I can browse into the catalog within the app, but when I click on the app (let’s say Osmand) it highlights very quick and make a “pop” sound but nothing happens…

1 Like

oh yeah, my mistake.

That’s strange. I’d try uninstalling and reinstalling F-Droid.

that was my first reaction!
but… it didn’t make a difference.

1 Like

I once had a similar problem on a Samsung phone. Have you tried updating the repositories? You can do that by hitting the menu button in F-Droid and then ‘Update repositories’ or whatever it is in English.

1 Like

Thanks for the idea! but it’s still the same… :confused:

@little_nemo you are also suffering from the “I disabled privacy impact” bug and need to enabled privacy impact in settings until we the first update. Sorry about that!


thing is… I haven’t disabled it. where can I enable/disable it? I don’t see it in settings…

Settings > Sound & Notifications > Privacy Impact


haha :smile:
thanks @paulakreuzer
I somehow assumed privacy impact would be in security settings… I looked in different other setting menu but didn’t think it would be in this one! is it possible to find somewhere the list of all menus and submenus?

it looks like I had disabled it… somehow… after enabling it, no problem for installing apps with F-droid, nice! :smile: