Can't get oandbackup to work properly

According to my new years resolutions I’m trying to get rid of all proprietary apps on my LOS FP2.
The only one left is Titanium Backup (EDIT: Oh I forgot, I also still use True Phone) and I’ll delete it as soon as I get oandbackup to work.

My phone is rooted, busybox is installed successfully and I granted oandbackup access to my external SD card.

As long as I back up to my internal SD everything works fine, but when I try to back up to external storage (which of course makes much more sense) the following happens:

  • I get an error message saying either “backup finished with errors” or “error on backup”
  • The app’s own error log stays empty
  • oandbackup does save apks and app data on the SD and from Amaze everything looks good
  • Unlike amaze oandbackup shows all backups on the SD card dated to the infamous date 1.1.2017
  • oandbackup does show all apps as backed up (if I filter the list for apps not backed up yet the list is empty)
  • I can restore the apps without an error, but no data is actually restored.
  • If I delete an app oandbackup won’t show it anymore even though it should display if I backed it up and filter the list for apps not installed.
  • If I move a backup from external to internal storage and change oandbackup’s directory to internal again it doesn’t recognize the backup at all.

So in short: oanbackup won’t successfully back up app data onto the external storage.

Exactly same behavior here. Like many backup apps it doesn’t create a tar file in the root file system, so the backed up data has wrong file and directory permissions all over, making it practically unusable. Titanium is supposed to get permissions right, but it’s too intrusive and causes system crashes in my case. I’m currently stuck to manual backups using the TWRP terminal.

1 Like

Finished testing AppWererabbit, it’s the only app that I know of that creates tar files with correct permissions and owners in the SD card. Unfortunately it doesn’t have a scheduling function, so backups have to be run manually. It beats having to reboot into TWRP and typing commands on the terminal window, so I’ll use AppWererabbit for now.

Well I won’t replace Titanium Backup - which works great for me - with another app that’s not on F-Droid.
I think I’ll just get used to regularly copying the oandbackups from internal to external storage.


I had the same problem and I solved by synchronizing the oandbackup folder located in the internal memory with my computer via the FLOSS Syncthing. None of the backups are on some untrustworthy company’s servers, they can be even transferred within the local network (i.e. from my fairphone to my router directly to my computer).

The advantage of this solution is that you can also keep several versions of the files (with a bit of reading the documentation this is not too complicated) while oandbackup itself always overwrites old backups.
And Syncthing’s documentation is quite good - I really like the software and its documentation and am happy with this solution :smiley:


I ditched Oandbackup because it was unmaintained and buggy, and I reluctantly moved to the closed-source Titanium Backup too (disabling any form of mobile/wifi communication because I distrust it).

I’ve just observed that Oandbackup got an update on March, 2018 (after 14 months of inactivity). Does the latest version of Oandbackup (0.2.13) work for you? Does it have the same behaviour described in the first post?

At least it still does not work when you have your backups on an external sd card. Not sure what is the exact reason for that. In addition I don’t get any errors when I tried to restore several apps+data. The apps were installed, but they looked like after a fresh installation (Background: Just moved from FPOpen to Lineage 15.1) I already was a little bit afraid that my data is somehow lost (I was about to restore via TWRP and try Titanium Backup again - don’t like it because of the reasons you already mentioned), but I found this topic and it gave me the hint I needed.

Just moved the backups to the internal storage again and everything went fine.

So for me it is still usable, but as you said there are not much commits to this app anymore so I’m not sure how long this will go on working on newer/upcoming Android versions.

1 Like

Another comment regarding oandbackup and handling external storage.

As the app got some updates the last weeks I scrolled through the changelog.
Accidentally I noticed that already in 2016 there was an update:>

0.2.11 (2016-01-17)

  • new permission: READ_EXTERNAL_STORAGE

So I tried to find out if there is a special permission or something else necessary to make this working.
I did not yet test this, but as soon as I have my new sd card available I will try if everything works fine with the option:

Eventually it is that simple. :wink:

Hi fellow Fairphoners,
I’m running Lineage OS 15.1 on my FP2 and I’m looking for a safe and hassle-free way to backup system + data. (Edit: I’d backup system w/ TWRP in any case, just looking for a way to backup user data and app data ; I hope this covers everything I should backup) I’m new to all these things, btw.
@Smojo, is oandbackup working for you now, with the permission enabled?
@Dabuh and @paulakreuzer, would you still recommend either Syncthing or Titanium instead?
Thanks a lot for your help in advance.

Tl;dr: For features alone I’d rather recommend Titanium, but if you care about free software it should definitely be OAndBackup.
In both cases you can use Syncthing to synchronize the created backups with another device (such as a home computer).

I am still using the combination of OAndBackup + Syncthing and it is working well. Although since a few weeks I get some error in oandbackup that forces oandbackup to use a deprecated way of backing up. Reading the github issues, the problem’s probably gone soon.

Just for clarification: Syncthing is for synchronizing files and whole folders with another machine (in my case, my laptop) whereas Titanium and OAndBackup are backup tools that store backups locally on the phone.

Answering the question “OAndBackup or Titanium” is not trivial. I have used Titanium (pro version) in the past and it totally convinced me in the categories features and usability. Personally, I think OAndBackup’s user interface is not so nice.
However, I try to use only free (as in “freedom”) software and Titanium is not free - OAndBackup is. I’m especially careful when it comes to software that is highly privileged; both OAndBackup and Titanium need root which is a particularly critical privilege.

Additionally, OAndBackup can encrypt your backup if you possess a PGP key and have OpenKeychain installed. Might be that Titanium can do that now as well but I don’t know. It is definitely a good idea encrypting your backups if you’re uploading them to a server that you do not own (e.g. Dropbox). If you are just synchronizing them with your own devices (e.g. via Syncthing) encrypting them is still a good idea but not crucial.


Thanks, @Dabuh.

This is also why I am considering using OandBackup, too. But there is another thread on backing up data which makes me insecure about its reliability:
It says here: “… and Oandbackup , like many other backup apps, record app data but don’t record system permissions and owners for each directory and file, so restored apps won’t work most of the time, and system integrity is compromised.”
Is that still an issue?

In the same topic there is also an explanation why recording system permissions and owners is difficult in Android.

For most apps that I installed explicitly - games, productivity apps, launchers and a lot more - backing up and restoring work fine.

For some system apps (which I did not install explicitly) some backups could not be restored on an upgraded Android. For example, after the upgrade from LineageOS 14 to LineageOS 15, OAndBackup could restore neither my contacts nor my WiFi access points nor my system settings. Generally, I’d recommend a separate backup of contacts and calendars - these are the most crucial data handled by system apps, in my opinion.

In some cases, restoring a backup worked fine after the upgrade (e.g. with Amaze file manager) but afterwards the app crashed because it needed to regain permission for accessing external storage (and with the restored backup the app knew that it had already asked for such, not knowing that I had upgraded the system in-between). In such cases, it is a good idea to first start the app on the upgraded system, let it ask for the permission, grant it and then restore the backup.


This is beyond my grasp, for now, I’m afraid :slight_smile: But I’l learn, hopefully.

I totally agree. If I have my contacts and calender synced with a trustworthy email provider (, in my case), that should be covered, right?
Thanks a lot for sharing your experiences!

I use it in the very same way like @Dabuh. OAndBackup + Syncthing.

I don’t have problems with backup and restore but e.g. apps which can become really really big like Signal in my case (which is currently 4.6GB :smiley: ) need a lot of time to back up and restore.
So I removed it from my oandbackup list and just use the Signal internal backup function and sync these backups with syncthing separately.

The error described below is due to a bug (?) in F-Droid which does not deliver the correct version for each device (here arm). This was described here:

The developer of the app seems to be about to move to gitlab.

There you also find the latest signed builds of oandbackup. I just uninstalled the app (strangely x86-64 was installed) and reinstalled the correct version (arm - build from CW48 2018 ). The error is gone.

I see the following error after starting the actual release of it:

Backup to internal storage still work fine. Backing up to a path on my external sd card I got a similar error. I did yet check this any further.

In the of the app you found:

busybox / toybox / *oab-utils*
a working busybox or toybox installation is required at the moment, but work is in progress to include all the needed functionality in a binary included in the apk. this program is called oab-utils and is written in rust.

So I assume this will be fixed soon.


Thanks, @Smojo.
Would you then recommend to download OandBackup from this Gitlab link you provided?

How do I know which version I need: arm, arm64, universal, x86, x86_64?

And please excuse if this is a dumb question: but is Gitlab something like F-Droid? It is recommended to use F-Droid because of update notifications, right? Is there a Gitlab App that does the same thing, or do I have to check for updates and install them manually?

Thanks a lot!

GitLab is a web-based Git-repository manager providing wiki, issue-tracking and CI/CD pipeline[6] features, using an open-source license, developed by GitLab Inc. The software was created by Dmitriy Zaporozhets and Valery Sizov,[7][not in citation given] and is used by several large tech companies including IBM, Sony, Jülich Research Center, NASA, Alibaba, Invincea, O’Reilly Media, Leibniz-Rechenzentrum (LRZ), CERN,[8][9][10] European XFEL, GNOME Foundation, Boeing, Autodata, and SpaceX.[11]

Quoted from the Wikipedia entry. It is an alternative to Microsoft’s Github.

If possible, yes.

Right, but if there is a bug in F-Droid like Smojo described it, I shouldn’t use it in this case?

so I should download from Gitlab, but I don’t know which version :frowning:

Is this still up to date information?

EDIT (in case anyone is interested):
I suppose it is arm, according to this, but I’m not sure how accurate it is:

So I first tried the universal apk flavor from F-Droid, then the arm.apk from the Gitlab site; in both cases, I get the same error as @Smojo posted before:

So unfortunately, I can’t get oandbackup to work either, and I’m giving up for the moment :frowning: :cry: If at some point this seems solved, please let me know. Thanks & best regards to you!

Hi @elfriedewien,
a lot of basic questions, but as I can see @JeroenH already replied. I would always recommend to uses your favorite search engine (I currently prefer “Startpage”) or Wikipedia first and try to understand this stuff at least basically. There is no need to be an expert in all of this.

Fairphone is arm processor / SoC architecture.
You can use an App like “CPU Info” to get some infos about your device. Also the Xposed Framework Installer App shows this very well and short.
So you should use the version from GitLab. And this is just the workaround for now for the F-Droid problem. Normally once installed F-Droid should still provide updates and inform you about this once one is available there - and you hopefully should stay at the correct version then (I cannot ensure this until the next update shows up in F-Droid). So you don’t have to be afraid that you do not get any updates anymore.

–> oandbackup-signed-arm.apk (just linked the latest build at the moment I’m writing this -> as already explained use this instead: from the instead to get the latest signed build)

I don’t get the error anymore. Did you completely uninstall the version which was installed before? Open oandbackup and use the 3-Dot menu and open help -> which version is shown at the top screen?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.