Can't get into TWRP on broken Phone anymore

I had problems with random restarts since a while, and i had to put my device on a loading cable to interrupt the restart loop it was in. This sunday, i got this restart loop, but then got the error message “Cannot load Android system. Your data may be corrupt.” with the options to try again (which results in an restart loop and eventually the error again) or to do a factory data reset, which is my very last option because i really don’t want to lose all my data. So i googled a bit and got to this article ✏ How to use TWRP without flashing it (e.g. for Backup), tried the steps myself and got into twrp on my device, the screen where i could choose “backup” and “recovery” etc. I tried the backup button and chose my data file which is roughly 8gb and the on-device storage option, because i don’t have a big enough sd card. But the leftover storage on my device was too small, so i chose to buy a sdcard on monday and left my phone in twrp mode on the cable of my computer. when i came home from work the next day, the device didn’t have any power left, because i closed my laptop and forgot my device wouldn’t charge that way. So i took it back on a power cable and it started this loop where it only shows the very first fairphone screen for a few seconds, then shuts down and after a few seconds the fairphone screen again and so on. So i tried to get into twrp anyway and i can get my phone into the fastboot mode, but when i try to boot it with my twrp image, it shuts down and starts in this fairphone screen loop again.

Is there any way i can stop this and get hold of my data? I already have a new fairphone 4, but i haven’t had any time to do the settings and transfer my data from my old to my new phone, so my biggest concern is to, in any way, get my data from this old device to the new one. That the old one is broken and can’t be used anymore, i don’t care about. Does anyone have any idea?

If the battery was fully discharged, it will take a while of charging to get the phone operational again. Let it charge the battery until the LED turns yellow at least, this will not be quick, give it time.

1 Like

I have the device now in fastboot mode on a power source just so it wouldn’t be in this restart loop all the time and hopefully will load the battery. Or do you think it’s better to let it be in the restart loop and hope that it would load the battery anyway?

The phone can’t operate without a battery or with an empty battery. Hooking it up with a power cable will not be enough to do anything with it in this state.
Just turn it off and let it charge until the LED is at least yellow.
I should have worded that clearer, sorry.

The problem is, that i can’t turn off my phone anymore. I can remove the battery, but as soon as i put it back in and connect it to a power cable, it starts it’s reboot loop again. So i just can let it do that and hope that it charges a little bit or i can put it in fastboot mode so it won’t restart all the time and then let it charge.

That would be my recommendation. So did you try this out?

1 Like

I let it charge in fastboot mode for a couple of hours and had then to remove the simcard to put it in another phone. Once i took my old one back on the charger it charged properly and didn’t went into restart loop anymore :blush: Then I let it charge to 100% and now twrp works again!! Many thanks for your help, i probably wouldn’t have had the patience to just let it charge otherwise.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.