Can't Create 5 GHz Hotspot after Android 12 Update

Hello Everybody,

after the Android 12 Update i cant set up a WiFi Hotspot Running on 5 GHz.
When i switch from 5 GHz to 2,4 GHz my Fairphone 4 is able to create a WiFi Hotspot.

Have anyone else this Problem?


Yes, it is not possible anymore. Maybe a bug.

Thats discussed here already more detailed


I experience the same, except that I can’t setup a 2,4 GHz hotspot either. Problematic when you’re a frequent train traveller like me :pensive:

1 Like


same for me here…

I experience the same, except that I can’t setup a 2,4 GHz hotspot either.

I got it to work on the 2.4 band by:
1/ putting the phone i Air-plane mode,
2/ turning on Hotspot
3/ deactivate Air-plane mode.
Hotspot working on 2.4 band :grinning:


I have a Fairphone 4 with the newly released Android 12. 5 GHz Wifi hotspot doesn’t work but turning off Wifi Connection and then turning on the 2.4 GHz Wifi hotspot works.

1 Like

Yes this is truely horrible. I use my phone quite often for work as a hotspot since we are prohibited from using public wifi on work devices. Now I am stuck with 2.4 band. Please fix this ASAP :frowning:

1 Like

Best you can do is #contactsupport and report the problem.

Done that now. Now we wait and see…

1 Like

Apparently a 2.4Ghz connection doesn’t work either. It is up for a minute before my computer disconnects from it and it is no longer visible. Had to dig out my old OnePlus phone to use as a hotspot. I wonder if there are the same issues if I install e/OS/…?

1 Like

Same problem for me. Can’t activate the screenshots either…

There is an option to automatically turn off the hotspot if no clients are connected. Maybe FP wrongly evaluates the condition? Can you try with this set to off?

1 Like

Hi! I have tried this but same issue. Now what I have done is a complete factory reset/wipe of the phone. It seems that this made 2.4Ghz work but I still can’t create a 5Ghz hotspot.

I just tried to open the AP on my FP4 and my Fritz.Repeater sees the AP on 5GHz even if 2.4GHz is configured on the phone. So I am not sure if there is an option to tun it on 2.4GHz explicitly. Switching the band to 5GHz preferred the AP gets turned off as you all described it already.

1 Like

Oh my ******* ***. Are there even tests? Is there any QC at all? I couldn’t even create a 5GHz hotspot on Android 11, that’s an expected behavior actually (at least in EU). But now selecting 2.4Ghz results in a 5GHz hotspot. That’s just stupid. I use a Wi-Fi hotspot almost exclusively for a baby monitor. You know what’s actually good about 2.4GHz? Unlike 5GHz, it will pass through a damn wall (or even multiple walls). :man_facepalming:


Thats my FP3 connected with my FP4 set to 2.4Ghz

This is really strange, after switching to WPA2 and back to WPA3 it is not on 5 GHz anymore but as configured on 2.4GHz. I checked it before with Wifi Analyzer app and the fritz repeater and both showed it on 5GHz while now it seems to be correct. Makes me feel kind of stupid :wink:

I have the same problem.