Can't connect to the camera


After an update to Kola Nut version 1.8.5 I can’t use the camera anymore. Even after a reboot I keep getting the error message “Can’t connect to the camera” any time I try to open the camera. Any idea?


Are you using the build-in camera app? You could try another, like Open Camera, and see if the problem persists.

Also, as always, clearing the cache of the app, and if that does not do anything also of the whole phone, springs to mind as a troubleshooting option.

Tried Open Camera with no results. Looks like open camera relies on the build in Camera. Also, when I go to “Manage App” -> All, I can’t see the build in Camera app among the application (so can’t clear the cache).

That is because the Camera and the Gallery are one application called “Gallery”.
:warning: if you delete the data (not cache) of the gallery you’ll loose all photos.

Thanks Paul. I deleted the gallery cache and reboot the phone but no luck. Do you know whether I can reinstall the gallery app?

The gallery app is a system app and therefore can’t be uninstalled manually.

But you could try @humorkritik’s suggestion to clear the cache of the phone. (Through recovery mode)

Ok… tried also to clear the phone cache with no result:-(
Perhaps is a physical problem with the camera rather than a software one.
Any suggestion about how to trouble shooting this one or shall I consider to send it out for repair?

Is there any tutorial about of the disassemble the camera or how to replace it?

Thanks again.

You can buy a new Camera here and there is also an iFixit guide on how to replace it.

But I’d rather contact support. They may help you identify if it’s a hardware or software problem and if the camera needs to be replaced they’ll probably do it on warranty.

Will try Paul. Thanks for your help.

I had a similar problem after installing a beta (
After reinstalling the update a second time manually it worked.

When the camera worked well before the update, I would rather try to reinstall the software than to change the hardware.

Best regards from Switzerland

Hi Bobby,

Any tip about how to reinstall the update manually?


Here you go:

i have the same problem. I can’t relate the problem neither to an update nor to the installation of another app that uses the camera. I also tried the suggested fixes without success. Does anybody have any new hints? Thanks,

Have you gone to Testing Mode to see if your camera works there? If it doesn’t the hardware is damaged and you should send your phone in for diagnosis.

Hey, thanks Stefan! Indeed both front and back camera fail in testing mode (. Does this prove that it’s a hardware problem? Then i could just buy a new camera and replace it, it just seems odd that both cameras fail at the same time…

I think that does prove that it’s a hardware problem, but maybe it doesn’t have to be the cameras, but could be the motherboard?

PS: Maybe it’s best to send the phone in for (warranty) repair.

1 Like

Mmmh that means some weeks without a mobile phone i guess. Well i’ll figure out what i do. Thanks for your support!

1 Like