Can't boot into OS after trying to restore system with TWRP

Hello everyone,

I rooted my phone and installed LineageOS 18 on it with success but in the end decided to go back to the stock system backup I had done with TWRP. Now the phone is stuck in a bootloop.
I can boot into recovery and fastboot. I tried installing the OS anew from lineageOS recovery and later from TWRP to no avail, tried different images, I still get stuck in the same loop.
I spent many hours and I’m starting to lose track of what I did so I think now is a good time to ask for help rather than bricking my phone not knowing what I’m doing. At this point I just want to be able to boot into any OS.
I also tried the FP3_flashall.exe from this page, it doesn’t seem to do anything either.
So I guess I broke something very fundamental that’s not directly in the OS but I don’t have the knowledge and I don’t know where to look.

What more information can I provide?

Thanks for reading and have a nice day!

I assume you did a factory reset too (well, at least it’s not mentioned here) resp. delete/format your data?

What does

mean? That FP3_flashall.exe works fine but still the bootloop - or does this flashing even not work?


Thanks for your answer!
Yes indeed I did a factory reset as well. I did it again just now to be sure, using the stock fairphone recovery.

FP3_flashall.exe process ran fine and showed no error, it actually seemed to have restored the stock recovery so that’s what I’m running now. The flashing seems to have worked but the phone is still bootlooping.


Update now:
So I tried to get some boot logs for FairphoneOS without success, no files existing in /sys/fs/pstore/ or /proc/last_kmsg.
I installed LineageOS again and this time after a failed boot I got some logs in pstore folder, I’ll include them:

(I didn’t manage to get logs for the FairphoneOS but I can re install it and try again if get an idea how to)
So in these logs I seem to see one interesting line which seems to trigger the reboot. Two of them mention things about: “Fatal error on the modem.”
Any idea what to do with it?

1 Like

Maybe you want to push modem_a, modem_b and all the other modem related stuff manually?

Thank you for your answer. I don’t see those in the official FairphoneOS files I downloaded. Where can I find them?

But I suspect it’s not the root issue still. What could be remaining after doing that FP3_flashall.exe? What is TWRP restore doing that FP3_flashall.exe doesn’t fix?

Here is a comment about that: TWRP for Fairphone 3 - #262 by _tmp

Basically, your phone has several different partitions called boot, modem, system etc (the post above the one I linked shows a script with all the important partitions and their names). Old updates had .img files with the corresponding names for those partitions.

However, there’s a new standard of naming partitions and Fairphone updates adhere to that - .mbn files, .bin files etc. Your phone doesn’t adhere to this standard as it is older, so one has to “translate” the new file names to the old ones. The file “partition.txt” does exactly this, it matches the old partition name standard to the new one.

What your flashall.exe does is basically just booting into fastboot and then executing all those commands like “fastboot flash modem_a modem.img”. Just instead of flashing a file originally called “modem.img” it flashes the corresponding newly named file “NON-HLOS.bin”. But you can do all this manually if you want to, if you look up the file names in partition.txt. Or, if you’re like me, you can copy and rename all those files to their old names and then flash them in the right order, This helps me make sure if have everything and didn’t forget something.

Frankly, even though I’m by no means an expert in this stuff but rather a rookie, I have a feeling that your modem partitions might have the wrong size or something, they don’t get flashed correctly and that’s why your phone doesn’t boot properly.

1 Like

Thank you, this clarify things up. Well flash_all did flash those already then, and I did it again manually for modem_a and modem_b without error.
I still don’t know how to get FairphoneOS boot logs, so I re installed LineageOS to see if it made a difference but the error logs are pretty much identical.
I see a big bunch of other errors in the console log linked before, I’m not sure modem is really relevant, it just seems to be the point where the shutdown begin.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.