Can't block my caller ID

The option to block my Caller ID is inactive . I know where you should be able to activate it in the phone setting menu in the account option. But the caller-ID option is inactive (grey). Does anyone know how to solve this.

On my Fairphone 4 the setting is also grey, but when I wait several seconds then the Caller ID turns black and by tapping on it I can choose Network default or Hide number or Show number.

2 Likes

Where would that be? I can’t find it (A13). :thinking:

(That been said, sometimes this option is blocked by the operator, so YMMV.)

Go to the Phone app
tap in Settings in the right upper corner
Tap on Calling accounts
Tap on the name of your provider
Tap on GSM call settings
Tap on Additional settings
Caller ID and wait several seconds

1 Like

Thanks, but I don’t see anything like that in Settings.

All I have in Settings (A13) is:

  1. Network & Internet
  2. Connected Devices
  3. Apps
  4. Notifications
  5. Battery
  6. Storage
  7. Sound & Vibration
  8. Display
  9. Wallpaper
  10. Accessibility
  11. Security
  12. Privacy
  13. Location
  14. Safety & Emergency
  15. Passwords & Accounts
  16. Digital Wellbeing & Parental Control
  17. Google
  18. System
  19. About Phone

The usual suspects would had been #1 and maybe #12, but it’s not in there either…

Not settings of the phone

1 Like

Duh! :man_facepalming:
Missed the “Phone” part… Thanks!

Super Lidwien. The waiting is the clue! I was to impatient. Thank you ver much.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.