Can't add bank cards to Google Wallet on FP4

I’ve recently purchased a FP4 and am trying to set up Google Wallet for payments with my bank cards. When trying to add a (credit/debit) card to Google Wallet, I get the following error message: “Your card couldn’t be added. Please contact your card issues for more info. You can also try adding a different card.”

I’ve tried adding cards from different banks, without any luck. I contacted my bank but they don’t seem to have an idea of what might be causing this. I checked the settings in Wallet, but everything seems to be fine (NFC turned on, phone meets security requirements, etc…)

Has anyone else had any issues in activating Google Pay on FP4? Any suggestions to solve this?

Hello and welcome to the forum. I understand that you were discussing the issue with your bank. But do they actually support Google Pay? In France, for example, virtually no bank supports Google Pay.


Hi Razem,
Good point but yes: according to the list of participating banks (as provided by Google Wallet itself) my bank does support Google Pay. I’ve actually tried with different cards from 2 banks and both appear on the list of participating banks, so - in theory - that shouldn’t be the issue…

1 Like

I remember having such an issue. I believe it’s not related to the Fairphone. I don’t remember how exactly it got solved: in one case it was either restarting the phone or uninstalling and reinstalling back the Google Pay app; in a different instance it was sufficient to wait for a couple of days and try again. I might be having memory aberrations - but try these three things. Ultimately, all the cards I wanted to connect have been connected.

For reference I was able to add a card only 2 weeks ago without any issue. You might want to check if your bank app has an option to initiate the setup in case that makes any difference.

But assuming you’re adding it via camera, check it picks up the number properly. I previously had an issue with a different card where it was somehow consistently managing to scan two digits wrong. In that case it was showing me a Terms & Conditions overlay for a Russian bank (in Russian), quite confusing!

Thanks for your suggestions. I tried these things (restart, uninstall and reinstall) but without any effect unfortunately

1 Like

Unfortunately my bank app does not have that option to add cards directly to Google pay from the bank app.

I see. :frowning:
Wish you the best of luck resolving the problem!

Hi guys, just wanted to let you know that my problem got - miraculously - solved. I was trying to add a bank card from my Belgian bank (which didn’t work) but since I also have a Dutch bank account I tried adding that card too. It required activating a bank card that I hadn’t used in a while but once that was done I was able to add my Dutch bank card to Google Wallet via the online banking app of my bank. Encouraged by this success I tried adding my Belgian bank card again and this time the Google Wallet app did allow me to add the card. I needed to authorize the card by calling my bank, and now everything seems to be working fine.

Long story short, I still have no idea why this was so difficult, but I guess my FairPhone wasn’t the bottleneck here. Thanks for your help in providing suggestions and feedback!

Case closed…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.