Can't access support ticket

To add any further details and/or attachments relevant for this request, simply reply to this message or head over to

Visiting merely displays:

The page you were looking for doesn’t exist

You may have mistyped the address or the page may have moved

If I click on the link I get a page to login in.
So perhaps you can try another browser.


I tried to sign in but for some reason it does not work with Firefox. There seems to be some kind of tracking blocker involved, maybe the Firefox built-in tracking protection. I haven’t found out what exactly is causing this.

Sign in works with Chrome for me, though, so you could try using a different browser.

I do too. The problem is that I created my account when I clicked submit on the ticket, because I didn’t login beforehand (clicking submit prompted me to create a account), yet this didn’t appear to link the ticket to my account, so it’s now totally inaccessible.

@Lidwien, I suppose I’ll have to register another account and now submit a ticket about my ticket, considering

@Ingo, have you tried about:preferences#privacy > Custom > (only) Cryptominers?

Didn’t notice

Emailed us for support? Get a password

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.