English

Cannot view/edit permissions for Signal Messenger

Hi all,
when going to Settings -> Apps -> Signal -> Permissions, I am getting a pop-up saying “Unfortunately, package installer has stopped” and it throws me back to the app list. It works for any other app I tested, but not for Signal. Any ideas, why this happens and how to solve?
I am running FP Open OS 18.02.0 without Xposed but with microG and signature spoofing via tingle to make Signal working.
Thanks!

Signal permissions are shown at me without problems.


But I use the standard OS with GMS.

I have, like tofra, no problems on the standard OS.

One thing you could do is wait for Signal 4.17.X to be released (it will entail an encrypted backup solution) and then try the official APK Signal provides on their homepage (https://signal.org/android/apk/), which does not rely on Google Cloud Messaging… Then you won’t need “microG and signature spoofing via tingle”. That’s most probably the culprit.

I believe I have a similar setup, running Fairphone Open 18.03.1, Signal 4.15.5, microg 0.2.4-108-g464d45d, using tingle for signature spoofing and no xposed. I can view the permissions as described (Settings -> Apps -> Signal -> Permissions) without any problems.
Not sure if that information is of any help for you. :slight_smile:
Simon

2 Likes

Thank you all for your posts! I did the update to Fairphone Open OS 18.03.1 without running tingle and re-installed Signal from the apk provided on their website (but since I do not have Play Store installed, I already had the version from the website that updated itself continuously). The result was: Signal still works without signature spoofing, but viewing/editing permission still raises the same error :frowning: Any ideas? Simon seems to have a very similar setup without problems. :thinking:

Finally solved the problem by removing and reinstalling Signal. Too easy! I can now view and edit the permissions. Signal is usable without any permissions, but especially the missing contacts permission makes it a bit unhandy.

BTW: I also removed microG to confirm that Signal now works without google cloud messaging. It works :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.