Cannot update TWRP

I have a fresh FPO 17.10.1 but I cannot update TWRP to twrp-3.1.1.-1-fp2. I tried flashing from inside TWRP and fastboot. And I tried TWRP_3.1.0-0_signed that had been working before. TWRP says that flashing has been accomplished but when I reboot to recovery the old version is still there. I tried to save the logfile to sdcard immediately after having flashed. TWRP says that it saved the logfile to /data/media/0 but there isn’t a folder media and a log file either nor a hidden one.

Is there anybody who has an idea what went wrong?


I had a similar problem once (but with an older version of TWRP). I tried to upgrade, fastboot said everything’s OK, but nonetheless the old version of TWRP was still installed.
What worked for me was first erasing the recovery partition via fastboot and afterwards flashing TWRP.
Didn’t investigate any further then.


The solution is to press and hold the Volume Up button while rebooting directly after flashing the TWRP image. This will make the phone boot the upgraded TWRP. Afterwards you can safely reboot to system.


I thought I did reboot into TWRP directly after flashing it. I can’t prove that now, of course.
Anyway, what’s the difference here? Why do I have to reboot into TWRP first, before booting the system? :confused:

Thanks, that worked.

Didn’t dare to erase recovery partition as I was afraid it could go wrong. (I already had so much trouble and work before caused by the last FPO update.) Thanks anyway.

If I knew I would be much wiser. Sometimes my manually flashed TWRP gets overwritten by a manual system upgrade although I deleted the recovery image from the manual upgrade package before. I guess there’s a copy of it in the system partition, but I didn’t check.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.