Cannot update Lineage OS + microG

I have LineageOS + microG 14.1 from January 23rd installed. There has been two updates since (January 30th and February 6th), but I can install neither of them.

Here is what happens: I download the update, I reboot into TWRP, and there I cannot find the file (the data/lineageos-update folder only contains the January 23rd file). When I reboot to the system and go to the update preference screen, it then shows that the update is not downloaded.

Is it happening to other people? What are my options to apply the update?

Why don’t you download and apply the update from there?

This is what I do: I download the update, I ask to apply it, the phone reboots to TWRP, and I cannot find where the update has been downloaded to. TWRP never applies the updates automatically for me, even though I have the most recent version (3.2.1-0).

Hm, maybe something is wrong with the updater app. You could try to clear it’s cache & data.
Or download the latest LOS file from here and update manually.

1 Like

Thank you for the suggestion. I tried again and this time it worked.

I also realised that although I thought had flashed TWRP 3.2.1, it was actually 3.0.2 that was installed. This explains why the OTA update did not apply automatically.


This topic was automatically closed 6 hours after the last reply. New replies are no longer allowed.