Cannot send SMS/texts from FP4

Hi fellow FP4 users and support,

I got the Fairphone 4 in spring this year and only noticed recently that I can’t send any texts (SMS). I hadn’t tried earlier, so I assume it never worked on the FP4. I can receive texts, make and receive calls and use mobile data without issues. I use the preinstalled Messages app (but have also tried with QKSMS with which it didn’t work either). When I try to send a text, it says “Not sent. Tap to try again.” and when I tap again, the error is displayed again. It probably goes without saying that when I enable the chat features to send texts via wifi / mobile data it works too but as soon as I turn off data, the error occurs again.

I contacted my provider (3 Ireland) and also noticed that I could not execute all of the codes they asked me to check:
#3300000# and ##002# to cancel call bars and call diverts worked fine but the code 50057672+353868002000# to change the SMSC resulted in the error “Connection problem or invalid mmi code” (I also use the preinstalled Telephone app).

I managed to change the SMSC number to the number that support gave me via the code ##4636## (because the SMSC entry in the Messages app is greyed out and therefore not editable and I got the error message mentioned above when trying to update the SMSC via their code). But even after changing the SMSC I still can’t send texts.

I only use that one physical SIM in my phone (no eSIM or dual SIM) and I have tried sending texts to both Irish and international numbers. I have also restarted my phone several times, I’ve reset the APN settings, manually selected the provider, and my provider support said on their side everything looks ok.

I inserted the SIM card into my old phone (Sony Xperia X) and was able to send texts successfully even using the old SMSC number. Neither of my phones are rooted.

Edit: Sorry, forgot to mention I’m on the latest FP version (FP4.FP4G.A.170.20220920) but the latest update was a couple of days ago and I had noticed the issue mid-September. Let me know if you need any other info from me.

I’m out of ideas,so I would be glad if anyone else had any :grimacing:


Hi and welcome back to the forum.

Have you used the SIM card in an Iphone before?

Please note this is a user forum and no official support channel ,please see #contactsupport

Thanks :slight_smile:

No, I never had an iPhone and never used the SIM card in someone else’s iPhone.

And yes, I read that this is not the official support channel and “only” a user forum which support rarely checks but I saw other people’s issues solved here by fellow users in the forum, so I thought I’d try here first as the Troubleshooting tool didn’t help.

And I just solved the issue on my own: I reactivated the “Carrier Services” app. I thought I had looked into the “deactivated apps” list during my troubleshooting but I apparently forgot. Before I deactivate any apps which I don’t know, I research to see what the app does and whether it’s safe to deactivate / uninstall it or whether I would disable some vital functions of the phone by deactivating an app. It seems for this app I didn’t research enough because the pages I saw read that it can be safely deactivated / deleted, and only the newer message features would not work anymore. And I saw that the “Carrier Services” app actually had a bug in 2020 which caused people on Android to not be able to send / receive texts, and uninstalling the app helped then. I also read that the app is supposedly there to support the newer messaging features like the chat feature (SMS/texts via internet). As mentioned in my initial message above, sending texts with the chat feature enabled ironically worked fine when the Carrier Services app was deactivated.

Anyway, the “Carrier Services” app is re-activated now but I revoked all the permissions it asked for and I also deactivated the default Messages app and am using QKSMS now (which is now able to send texts successfully too).

Hopefully this helps others who were as stupid as me to deactivate an app which is apparently vital to sending texts :wink:

FYI, I saw that the link to the troubleshooting guide in the #contactsupport wiki points to a non-existing page (should be this one now I believe). I might not be senior enough in the forum to be able to edit that wiki to update the link but maybe someone else is?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.