Cannot reinstall Fairphone OS or Fairphone Open OS - only Lineage

my strange problem began with watching a video on Twitter with a Fairphone Open 18.04.1 on a Fairphone 2: suddenly the display froze, and I had to reboot.
This reboot, however, entered a endless boot loop. After the initial logo the Fairphone “startup bubbles” appeared two or three times, then it stuck, and rebooted again.
I searched the forum and tested all recommendations (taking out the cards, checking the slim case and the buttons, finally doing a factory reset), also this and this.

Then, I decided to try a reinstall and flashed the phone, first with Fairphone Open, then with Fairphone OS. In both cases the phone started into the endless boot loop.
After that I even tried Ubuntu Phone - with the same result: new startup logo (so I seemingly had installed Ubuntu successfully), but endless boot loop.

Now the strange part: With almost all hope lost, I tried Lineage OS according to this wiki. This means, I flashed the phone with a TWRP image, copied the Lineage zip to the sd card, and reinstalled using TWRP. And it worked!

So, unintentionally I now have a Lineage 14.1 running on my Fairphone, and I give it a try and test it.
But: I don’t understand what caused the problem, and why I cannot install Fairphone Open OS or Fairphone OS. Any suggestions?

Kind regards

The guide to install LineageOS tells you to wipe partitions in TWRP (“Installing LineageOS from recovery” steps 5 and 6).
That actually helps when something is wrong with an OS installation. Did you do something like that before earlier install tries?

Perhaps you did a factory reset before?
Mind, a factory reset on the Fairphone 2 doesn’t wipe partitions, it only deletes every user data and Apps and leaves OS and recovery as is, so if somehow the OS is corrupt, it stays that way after a factory reset. If somehow the system partition is corrupt, I guess it stays that way after a factory reset.

If you still feel like it, try to install Fairphone OS or Fairphone Open OS now. But wipe the partitions before that as you did with LineageOS.

You can easily install Fairphone Open OS with the TWRP recovery …

You can even use TWRP to install Fairphone OS (but in this case the manual install via fastboot is recommended) …


Thank you very much!

Using the extended wipe of TWRP, and then installing did the trick!

(I had tried the switcher files, which cannot be installed with TWRP.)



two months later, again after watching a youtube-video, I have the same endless reboot-phenomenon.

This time, unfortunately, it doesn’t matter which OS I install: Fairphone OS, Fairphone Open, and Ubuntu Touch all install flawlessly, but enter an endless reboot then.

Only Lineage OS boots properly, but lineage-15.1-20180910 doesn’t recognise wifi.

Is my phone bricked, or does anybody have another idea to end the reboot-loop? I would still prefer to run Fairphone Open.

Kind regards

That would indicate a hardware problem I think.
The only thing I could think of otherwise would be tweaking CPU settings to perhaps work around a performance or heat problem … e.g. with Kernel Adiutor or with LineageOS performance profiles.

If you happen to have #fairphoneangels in your vicinity, they could perhaps help by swapping modules to find out whether a module is at fault, even if the expensive core module seems most likely to me.

Else … install one of Fairphone’s OSes and #contactsupport

… and quickly for a possible warranty case, if it was the end of 2016.

Can you give more details on that?
WiFi works fine for me.

Edit: Wait … does LineageOS not do the reboots?

Thanks for answering.
Lineage OS does NOT go into a reboot loop - that’s the weird part of the problem.

On the wifi problem: Although I installed the latest, I get a

System UI isn’t responding
Close app // Wait

when looking for a wifi network. Whenever I switch on wifi in the settings, it switches itself off after a few seconds.

The installation of Fairphone Open ends with:

Updater process ended with ERROR: 7
Error installing zip file ‘external_sd/’.

Couldn’t find out what ‘ERROR 7’ is. (Ubuntu installed without errors but entered the boot loop nevertheless.)

… seems to amount to some unexpected or incompatible data already present, but I assume you wiped everything (as with the earlier problem) before changing OSes?

Can you try at a completely different place, where none of the networks present in the location where the problem occurs are there?

There are cases where certain router configurations seem to give the Fairphone 2 some trouble …

1 Like

In the Wi-Fi preferences, I have the MAC address 02:00:00:00:00:00. This seems odd to me.

Some internet searching brings up a lot of hits for this address, either when WiFi is off (but my settings show a valid MAC address when WiFi is off) or developer trouble when fetching the MAC address via the Android API.

Is it still the same after you turn off the phone completely, then turn it on again?

Can you try to (re-)flash the latest

And …

I wiped everything a dozen times, and I tried different modem.zips. No change.

Besides that, the battery drain of Lineage OS is absolutely intolerable.

This is also not normal.

I’m giving up, I suspect broken hardware.
Until anybody else comes up with something, it seems your options are module swapping by #fairphoneangels to identify a broken module, or installing one of Fairphone’s OSes and then #contactsupport .

1 Like

Nevertheless, thanks for caring.
After two years and seven months my fairphone experience seems to end.

A modular phone doesn’t make sense if you can only replace minor modules like cameras or the display. Repair of the core module costs at least 378.05 EUR according to support. It’s cheaper to buy a new and more recent phone.

1 Like

For what it’s worth … you can replace the core module yourself, but it simply is the most expensive part of the phone …

… and it’s the same core module I bought almost three years ago … still with proprietary elements. :frowning: A fully free module would be worth the money.

Maybe the Librem 5 by Purism is something for you, then. But it got delayed until 2019 recently.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.