Cannot order things from (“something went wrong”)

I’ve been trying to order a product (FP4 screen protector) for about 2 hours, but I get “something went wrong” each time I try it. I also tried other products, such as the screwdriver, same error.

I tried iDeal and Paypal. I used Linux with Chrome and Firefox, Android with Firefox and Mac with Chrome.

All are not working. I suppose this is an internal issue? Could someone else try? If you get passed the point of selecting a payment option and get redirected to a bank, then please let me know. Then something might be blocking it here locally somehow.



How far did you get?

Just tried with Firefox 78.15.0esr (64-Bit) on MacOS 10.11.6 from Germany

I won’t go further than this as it would finalize the order. :angel:


For iDeal and Paypal it’s save to go one step further. That’s where it fails for me. Also contacted Fairphone support in the afternoon already via mail, no reply yet.

If this gets resolved along with the current bootloader unlock code issue, then it would have been the same service misbehaving on Fairphone’s side … Is there an offline version of the bootloader unlock code generator? - #2 by jftr … wouldn’t that be peculiar? Let’s see.

1 Like

same problem here. :frowning:

1 Like

When I tried to enter the shop today, I was presented with an error page quite regularly

429 to many requests

Maybe there is some trouble today?

1 Like

I hope they will fix it today… My Fairphone 4 is coming soon and I still can’t order the basic accessories such as a case, screen protector and charger. At least the screen protector is in stock now, but now their online shop doesn’t work.


I’m trying to buy some aThuscessories for the Fairphone 3, but on the check out page when selecting a payment method and clicking on “Place order & Pay” I see an empty error notification at the top of the page:

Further I see in the Network Tab of the Browser for the post call<myIdAndThusRemoved>/payment-information a 500 Internal Server Error with the message Server internal error. See details in report api/729352289253.
I’m trying to purchase from Germany and I’ve also seleceted Germany in the top menu drop down.

Best David

1 Like

Welcome to the community forum.

I moved your post here as it seems to be about the same issue.


Happened to me about half the time over the last two days.
Probably too many requests :rofl:

Hi everyone,

Thanks for flagging. Sorry about that! We’ve alerted our team and they are currently looking into this. We don’t have an estimate timeline yet, but I’ll pop a message here when everything has been smoothed out. :slight_smile:


It should now be working once again. :white_check_mark:


Thanks a lot, yes it is resolved for me!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.