Cannot open attachments in K9 mail client

My e-mail clients tell me when I try to open an attachment, that they cannot find a suitable app.
I use the standard client and I use K9.
I tried this with a doc, a pdf and a gif file.
K9 lets me save the attachment. I did that with a gif from a boardingpass and the foto viewer could open that gif, so the file is not corrupted.
What’s wrong with my FP?

Edit: Quickoffice does not exist anymore.

Hi Bart,

that is indeed strange. I use K9-Mail as well and had no such issues.
Do you have a PDF/Word compatible app installed? There is no preinstalled app for this type of documents. If you use the Play Store, you can try Adobe Reader for PDF and Quickoffice for Word, if you don’t want to use Google and Play Store, F-droid has “Document Viewer” for PDF at least.

Good Luck!

QuickOffice reads PDF files as well, so no need for Adobe Acrobat Reader as well.

Quickoffice doesn’t seem to be on the app store anymore. I downloaded WPS office. It indeed solved the problem for documents.
For PDF and Gif, it works now when I press save. The file is indeed saved, and immediatly opened. The open button still gives the same error message,
But I can work with this, So I’m fine now.


@Bart_de_Leeuw yeah apparently Google have very quietly pulled it. Luckily I backup up my apps before I did the cherry update yesterday

Workaround confirmed as working, therefore topic is now closed. New replies are no longer allowed.