Cannot install System Image because signature failed and /product not found

I unlocked my Fairphone to install LineageOS Recovery and Operating System.
In thss Workflow i used Magisk Manager, too. Actually i have TWRP flashed. In TWRP ich see often that /product is not found. I think i have Problems with the Partitioning of the internal Flash Card, so i can’t flash any Operating System zip. Is this right?
What can i so to solve the Problem, and to go on with with Flashing the System?


So just to understand: you installed Lineage Recovery and from there Lineage OS (official/unofficial version)? After that you tried to root your phone using Magisk? How exactly?
You know TWRP is not officially supported? You really flashed it instead of booting it? Why did you flash TWRP?
Now you want to flash any OS and it does not work? What happens when you try and what do you want to flash?

I Unlocked bootloader, then i installed magisk to root the Phone.
I think this was my Mistake.
Then i flashed the Unlock State and flashed the Final Lineageos recovery. Next i wanted to flash Lineageos 20 but got verify error. The same with TWRP. The Stock Rom FP4-FP4D-factory same. I found error with /product not found. So i think i have a Partition Problem. Right?

Overall I think thats out of knowledge, still: did you try to install the whole FPOS manually using the script or what exactly did you try? What PC system do you use? Any chance to remove Magisk?
What is verify error? So did you boot into TWRP or really try to flash it (what I think is no advisable).

Magick isn’t installed anymore because the Phone has actually only a running bootloader and running recovery. I booted into twrp and tried so flash the LOS System, Image with INSTALL from sdcard. twrp says invalied zip format and failed to mount ‘/product’
adb sideload says failed to verify whole-file signature E: Signature Verification failed. error: 2


so did you just try to manually install FPOS (def dont lock the bootlaoder!) and than start from scratch with the rest?
When you use windows there might be a bug in the script you might find info here in the forum (script aborts without error)


I tried to flash the Phone, but the Script says
critical partitions are not unlocked
Whats wrong?

Hello, my phone runs again.
Thanks for help

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.