Cannot delete photos from SD card

Since updating to Android 6, I cannot delete photos anymore. I use Open Camera to take them and store them on my SD card. I have tried deleting them in Gallery or in Storage & USB (in Settings). In both cases, the pictures disappear but they reappear when I go back to Gallery to check. If I connect my phone to my computer, I can delete the photos - but it isn’t practical because all I see are the file names instead of the pictures. Any explanation? Could this have to do with the new way of granting permissions?

My screenshots are stored in the internal memory and I have no problem deleting them.

I tried looking at the settings of the Gallery app but all I get is a black screen.

I also have trouble reading larger videos filmed with Open Camera - and I cannot look at them on my computer either, because Android File Transfer doesn’t seem to manage them and I can’t transfer them by e-mail because of their size. What I noticed, though, is that due to all those files I can’t delete, my SD card is quite full. Could that be the reason?

Thank you!

Just an additional note: I installed Amaze from F-Droid and it doesn’t let me delete the files either. I always get these messages asking me to select the root directory. I’ve never understood what I was supposed to do there - following the thread to the directory I am in creates a new, empty directory there every time (which I can’t delete on the phone anymore either).

Oh, and just to say: my phone isn’t rooted. I have trouble imagining I have to root it to be able to delete pictures - is that the case?..

Hello there Linda. I have the same issue and my fairphone is rooted, so this is not the problem

Hi Raul!

Thanks for your reaction! Have you found any other discussions or information on this issue? Do you think it’s the same thing for everyone? My post doesn’t seem to be triggering too many reactions. :wink: I wonder if it’s because the discussion is going on somewhere else…

Android 6 changed the permissions apps have on the SD card, apps can now only make changes to files inside their own data folders. Perhaps this is why the gallery app cannot delete files in the open camera data store. Does the built-in file manager allow deleting files (Settings > Storage & USB > Explore)?

Thank you! Actually, deleting the files in the built-in file manager didn’t work when I wrote my first message but it did today! (I had to restart the phone for the changes to be applied in Gallery). I think I did an update since - maybe the permissions have been corrected.

It still doesn’t work the other way round, though: deleting pictures in Gallery makes them disappear for a moment, but they reappear shortly after.

Do you know if there is another way to refresh folders (rather than shutting down and restarting the phone everytime)?

I suppose there is no way to select the SD card as data folder for Gallery, is there? (When I choose “Settings” in the Gallery app, I still get a black screen.)

For me apparently yes, but after deleting the images with the manager they come back to.the gallery:confused:

Ok, now i see… My problem is not with sd card files… The images or videos wich i cannot delete are in internal memory.
When i try to delete them using the built-in file explorer/manager a message pops up saying “some files can not be deleted”.
Maybe this is a diferent issue…?

Most gallery apps actually use a database of media files on the device, rather than looking at the folders directly. This explains why there is lag - the file is gone but the media indexing service hasn’t figured that out yet, and hasn’t updated the database that gallery uses. Usually waiting a little is all that’s required. I’m not sure how to force indexing in any practical way - as you’ve found out, a reboot works, as does deleting data for the media storage app. The problem with latter is everything then needs to indexed again, which takes a lot of time and battery if you have many files. Maybe someone else knows a way.

I’m not familiar with the gallery app and I don’t have access to an FP2, so unfortunately I’m not much use in finding a way to get the app to behave.

I’m not sure what’s going on. There is a chance that the files will be gone after a reboot. Other than that I wouldn’t know what to recommend at the moment.

Thanks a lot! I’ll try deleting files in the built-in explorer and hope for the best… Still happy to take more advice if someone else has found a solution!

This topic was closed as it attracted spam. If you have a similar issue you can contact a moderator to have this topic reopened.