Cannot create CalDav Account - Reenable Privacy Impact


I added a Google account to my FP2 no problem. Now, I am trying to add a CalDAV sync and a CardDav sync account and both do not seem to work.

When I select Settings -> Add an account, both apps are in the list of available account-types. When I select one of them, I can give my username and password. The I select next and my access data is checked successfully, I am asked

  • to give a name for the address book to be synced (cardDav)
  • to select the calendars to be synced (calDav)

When I do and click Next, I get back to the previous screen with my access data.

Thus, I can switch back and forth between the two dialogues, but the account is never created.

Any ideas? Is this a bug in FP-account management or in both apps?

Thank you

What app(s) are you using for this? I could imagine it’s an issue with the app. I had no problems to set it up.

Maybe you can try if it works with another app.

I just received my Fairphone today and in general I’m impressed and happy.
But there is one major big BUT and maybe someone can help me or try to reproduce the issue:
I’m using the app “CalDav-Sync” by Marten Gadja to add an caldav-account in order to connect and synchronize with my selfhosted OwnCloud-installation. When I follow the “set-up-wizard” in caldav everything is fine, i.e. my calendars are recognized (so the connection is ok). But (this is the big BUT) I cannot complete the action of adding the account. After selecting my calendars and pressing ‘weiter’ (forward) the wizard always goes back to the first page where the connection-details have to be provided and therefore the account is not added.
Any help/idea is highly appreciated as a phone without my calendars is useless for me. Using google is not an option for me neither as setting up OwnCloud was a major (first) step in getting out of the google world.
As a note: In my old phone I set up the connection successfully without any issues.
Another note: CardDav exactly behaves the same, i.e. no contacts synchronisation :frowning:

Thanks and cheers

This could related to this bug:

Re-enable Privacy Impact in Settings > Sound & Notifications, maybe that helps.


Thank you for merging my report to the right place and for giving the link:

The workaround described there solved the issue.
Unbelievable good support/community, it took me 15min. to go from :scream: to :sunny: