Cannot access root anymore

Hi there,
i was trying to open some system files but my file manager (FX File Explorer) can’t access root anymore.
In the past, when I tried to do the same operation, it would prompt a message asking if I wanted to give root access to the file manager app I was using. Now I don’t get this message anymore, it only says "FX was not able to obtain root/superuser access to perform this operation. Ensure this device is capable of root access and that you have granted root access to FX File Explorer using your installed “SuperUser” application."
I have already checked under Superuser settings, Declared Permission is not checked and Automatic Response is "Show confirmation dialog for new requests"
Any idea about how I can solve this issue?

The first thing that comes to my mind (since you have checked all relevant settings), is to reinstall Fairphone OS, so the system files get back to default.

A bit drastic solution…
Anyway, I would love to do that, that problem is that my updater doesn’t work (If I click INSTALL it starts “downloading” and after a second it goes back to INSTALL and nothing happens), and so I wanted to copy some stuff from the system files before I try to reset the phone.

Whoa! That is a very strange problem you are having.
If trying to update through the updater app doesn’t work then maybe manually updating is worth a try?

1 Like

A reinstall of Fairphone OS won’t reset the phone. You won’t loose user data. Just system files are reverted to default (you’ll loose Google Services, for example, and need to reinstall them.)

Have you tried the following?

1 Like

I’m having a similar problem. I have an FP1u. The USB charging port broke so I’ve had to replace the motherboard. I didn’t have the phone backed up, so now I’ve got the new motherboard installed, I’m trying to install Titanium Backup, so I can be better prepared in future.

However TB is saying that my phone isn’t rooted, despite my having chosen the option to give it superuser access. I’ve checked under ‘superuser’ in the settings, where the log says access to TB was ‘denied’.

I’ve also only just updated to Kola Nut (this morning). Any suggestions would be great. Thanks everyone.