Can you feel it coming OTA tonight? - THIS UPDATE IS NOT OFFICIAL!

I think it’s the first guess. AFAIK the code base was always unified.

Looks like this is the case. I looked a bit into it and it seems that they only ship MM (FP2-gms-17.04.3) for users with FP2-gms76-1.13.0 installed. :wink:

I could also imagine that a big announcement might have triggered a sudden updating rush. Maybe it is actually smarter to let the news trickle through gradually.



I was really happy to see that I can install “Fairphone OS 17.04.3” over the Updater App. But directly after the reboot, a message appears, that it was not succesful.

Could the reaons be that I encrypt my Android? But then how do I re-instal the new version? Do I have to go back to factory default? I hope not…

Kind regareds

I got the OTA for 17.04.3 just now and I am trying to update now but it’s doing the “Starting Android… Optimizing app X of Y…” for the 5th time now. Seems to be in a loop. Is it save to pop the battery and hope it boots normally after cooling down a bit?

Yes. And if it doesn’t help please continue here:

Pff, thanks. It started to become very hot. I am letting it rest for a while, charge the battery and try again later.

Great to hear Android 6 is finally here.

And the time to asking: “How old is my last backup???” :sweat_smile:
With a fresh backup the upgrade process is much more relaxed.

Fairphone must have released it accidentally earlier as the updater app hasn’t been updated recently. The update mentioned is from 31st march.

The same for me. Updated the updater, then started the download and let it reboot. Then it stops in the system recovery telling me that the footer is wrong, signature verification failed and installation aborted. Luckily I can reboot and return to Android 5.1. I have even tried it a second time with exactly the same result. Any idea what is wrong there?


I have upgraded to Fairphone OS 17.04.3 from Fairphone OS 1.13.0 via Fairphone OS 17.04.1 which was always mandatory as per OTA update multiple times, with and without encryption of Fairphone OS 1.13.0.

While the update to Fairphone OS 17.04.3 never failed, I had one time an issue upgrading to Fairphone OS 17.04.1. The phone rebooted with one retry in boot loader normally in Fairphone OS 1.13.0. A second time using OTA update worked out well.

I would assume it is a timing issue rather than specific to encryption setup. Would you fear to try out a second, or for @Martin_Anderseck a third time?


Updating the fairphone2 updater app (via manual check for fairphone offerings at google play store and updating the updater app there) from within still android 5 then it starts showing the fairphone 17.04.03 update, all right. It upgraded to android 6 then. Via reboot, then four blue dots animation during bootup for a while, then apps optimisation then it was finally at the lock screen. Update via WiFi.

Whole fairphone2 became kind of hot after the upgraded succeeded but then eventually cooled down again. I miss the Android 5 lock screen though pretty severely :frowning: Too bad.

I’m not 100% certain any more, but I believe, I’ve had it “optimizing” once two times. It finished fine afterwards, but at some later boot, it started optimizing again two apps (for which it doesn’t give more details). But I have also installed a few (maybe just two) apps in between.

I just wondered why the particular optimization is performed at a later boot. Maybe has to do with some new Java Compiler in Android 6 (I really forgot if it came into production version, Google tried out a lot.)?

I could imagine that it doesn’t finish “optimizing” all apps in one row, maybe it needs several runs to finish all of them. But if “Y” is always the same high number, then I have no clue about reasons.

After the update my Google Play Store app states that the “device certification status” is:
“not certified”

Anyone else here with the same problem?
You can check by opening the Google Play Store app and go to settings, its there at the bottom.

l’m a little bit confused. Is this the official Update to Android 6 or is it a mistake? I really want to click that button. Has anyone updated without facing problems afterwards?

I added bringing back the old FP specific features as a feature request.

We don’t think this is an official update. It appears to be the beta version still and shouldn’t be released generally. So i wouldn’t recommend anyone else updating right now. Word is that it won’t be for another week or so until Google have green lighted the official release

Yes, it really seems this update (to the updater app) was released to the play store before the update to the OS was actually approved by G%§$e.

The update was thoroughly beta tested and yes - has been successfully installed many times, but it still doesn’t have the official go ahead from G%§$e. So if you are afraid better wait.

Hmm, I would be surprised, as there is one critical and one important bug in bugtracker, which might probably resolved before release or found to be not critical enough. And there is already a new update in pipeline, so I don’t think that 17.04.3 would be the first release version.

@Jens_Fischer: Practically I believe it was accidentally visible?!? On my Android 5.1 mobile I also don’t see this update.


Euhm okay now I am confused. People who “manually” updated the updater and then went for this Android6 (pre)release or unofficial, how will we advance to the actual real official Android6 for FP2? I didnt want to mess up my phone and I didnt plan or intend to go for a beta or half baked software. Hope this is not a dead end for us accidentally early adopters or us jumping the gun. Thanks.