Can you disable google searchbar on FP4?

I don’t know and I don’t know if I want to try :fearful:

no risk no fun
you’re not a Hulk my friend… :wink:

as far as I know, the apps that make it to F-droid repo are actually preemptively screened by real humans first, as opposed to Play Store where all kinds of garbage gets added daily. I’m yet to hear about F-droid serving kinds of malware, while some Play Store garbage apps show up in the news every few months. it’s a strictly FOSS-only store, which while of course doesn’t automatically mean that there’s never going to be any malicious apps in there, it greatly reduces the risk of that happening.

4 Likes

Is there a way to get the search engine provider selection menu again? Since it shows up after a factory reset, it might be that resetting an app would trigger this again. Does anyone if this is possible and which app would need a data reset?

According to support the only way seems to be a factory reset currently. See this post:

I managed to get the search selection back, analogous to this thread on XDA (for the SetupWizard).

$ adb shell settings delete secure selected_search_engine
$ adb shell pm enable com.google.android.apps.setupwizard.searchselector
$ adb reboot

Tried it a few times on a FP4 that had already gone through the selection and could reliably change the search provider after a reboot. If you are running root be careful though, the search selector really doesn’t like to play nice with Magisk, I didn’t manage to get it to work on a rooted FP4.

8 Likes

Nice! I’ll try it once I’m near my laptop again. Too bad the app cannot be reset within Android itself…

Yeah I tried that first, but haven’t found a way to clear that settings row directly on device. The integrated Android Terminal has been removed it seems and Termux needs root privileges to access settings / pm. There’s no adb on devices anymore so that won’t work either.
It’s probably super obvious and I just haven’t figured it out, maybe someone else knows a way :man_shrugging: :slightly_smiling_face:

Will this trigger the setup wizard to go over all settings including the prompt for logging into your Google account or is it just the search selection? I don’t use a Google account and don’t feel like tinkering with that again.

No, this only triggers the search selector screen / notification.
At least all the times I tried, no guarantees though :smirk:

2 Likes

So I’ve come to the conclusion you cannot get rid of the search bar on quickstep launcher right ?
Would it be possible to force it to use another browser at least ?

I don’t like the solution of switching launcher as it breaks gestures fluidity, and I really like those gestures…

You can use this Magisk module to get the gestures working with the Lawnchair build from IzzyOnDroid (a bit out of date). Works great for me with immersive navigation enabled :smiley:

1 Like

Ahh, maybe not for me. I removed that package incl. data :see_no_evil:

You can change to any of the search providers. For each one an app is installed. I use duckduckgo now. I already use that in Firefox, so it’s not great to have another browser installed just for a search bar. I would use an alternative if they weren’t that buggy. Quickstep is open-source and with DDG it’s okayish.

IMHO startpage.com as searchengine!

After one day the searchbar was reset back to Google. Good that I don’t have to reset my phone to get that search selection menu again :nerd_face:

Huh, weird, the device I tried it on is still using the search engine I selected :thinking:
What’s the output of $ adb shell settings get secure selected_search_engine?

It’s not about search engine, it’s about the browser unfortunately :frowning:

Really ? Does this module prevent the micro-second redraw thing when going back to homescreen from other apps to happen ?

Edit1: Just tried it. Wonderful, thanks ! Somehow, it seems that when changing lawnchair settings the recent slide gesture gets broken and I have to disable/enable gesture from system settings to get it back, you get this behaviour too ?

Edit2: seems like Lawnchair 12 alpha 4 is also compatible, so everything is going perfectly fine in the best of the worlds :smiley:

I disabled Chrome. It opens Firefox for everything (as far as I can tell).