Can’t turn off Outgoing call barring on FP5

Hi. I have a FP5, all updated and it works fine abroad with data, but outgoing calls are barred and I get network error messages when I try to switch the option off.
I’m in Croatia (with a UK YourCoop SIM) and switching networks sometimes works but not consistently.
Any suggestions welcome. (Yourcoop says my SIM looks fine at their end). Thanks.

Have you checked your account details (including roaming) on the YC website? Options sometimes get turned off for unexplained reasons.

Which barring setting(s) is / are on?
Did you try the “Deactivate all” option?

You might want to turn off Wi-Fi calling if it’s enabled.

Thanks. I couldn’t see an option to view my roaming status on my account page but it’s turned on on the phone & YC confirmed yesterday that the settings were ok at their end.
I’ve switched off Wi-Fi calling (no change) but then I switched networks and that (as before) has worked. I’ll see if it lasts this time. Previously it reverted back to barring, and switching networks didn’t help.
It’s only outgoing call that are barred.
If I try to change anything on the Barring options page I get “network or sim error.
Thanks again