Can t install FP3 OS offline using ubuntu script

Hello , I messed up with TWPR and now I need to install FP3 OS with my computer . I use Debian 11 and script for me does not work . The message error is : " chmod: cannot access ‘FP3_flashall’: No such file or directory " .
Thanks for Help .

Hi and welcome to the community forum!

I only have an older version of the install files, so your version numbers will be different, but the general principle should be clear.

So, assume the downloaded file is called FP3-REL-Q-3.A.0107-20210513.132633-user-fastbootimage.7z and also assume it was downloaded to ~/Downloads

First you need to unpack this archive file. Either with some GUI tool (not sure what the default is for Debian) or on the command line (which may require to install the corresponding command line tool named “7z”).
The latter would be

cd ~/Downloads
7z x FP3-REL-Q-3.A.0107-20210513.132633-user-fastbootimage.7z
cd FP3-REL-Q-3.A.0107-20210513.132633-user-fastbootimage
chmod a+x FP3_flashall
./FP3_flashall

The first line changes the working directory of your shell to the Downloads folder in your home directory.
The second line unpacks the archive. This creates a new directory where all the unpacked files are place.
Line 3 changes the working directory to the newly created directory where the unpacked files are.
Fourth line makes the script executable
Fifth line actually runs the script where you can follow the instructions.

In case you have not installed “7z” yet, you can easily do so with sudo apt install p7zip-full.

1 Like

Hi Ingo thank you for your prompt reply . I downloaded and unzipped this file : FP3-REL-8901.4.A.0017.3-gms-15368f27-user-fastbootimage.zip . I meticulously followed all the steps and when tried to flash the file as root user I got this :

/home/…/FairFone/FP3 OS ./FP3-REL-8901.4.A.0017.3-gms-15368f27-user-fastbootimage# chmod a+x FP3_flashall
chmod: cannot access ‘FP3_flashall’: No such file or directory
root@…:/home/peto/FairFone/FP3 OS ./FP3-REL-8901.4.A.0017.3-gms-15368f27-user-fastbootimage# .
I tried to solve alone but no way .

What do you see, when you type these three commands instead of chmod a+x FP3_flashall?

pwd
ls -l
whoami
1 Like

pwd :home/…/FairFone/FP3 OS ./FP3-REL-8901.4.A.0017.3-gms-15368f27-user-fastbootimage#

ls -l : -rw------- 1 … 10 Jan 1 2009 android-info.txt
drwxr-xr-x 2 … 4096 Sep 24 21:32 bin-darwin
drwxr-xr-x 2 … 4096 Sep 24 21:32 bin-linux-x86
drwxr-xr-x 8 … 4096 Sep 24 21:32 bin-msys
-rw-r–r-- 1 … 147 Sep 24 21:32 flash_fp3.bat
-rwxr-xr-x 1 … 8414 Sep 24 21:32 flash_fp3.command
-rwxr-xr-x 1 … 276 Sep 24 21:32 flash_fp3.sh
drwxr-xr-x 2 … 4096 Sep 24 21:33 images
-rw------- 1 … 506543 Sep 24 21:33 MD5SUMS
-rw-r–r-- 1 … 1028 Sep 24 21:32 README.txt
-rw------- 1 … 699151 Sep 24 21:33 SHA256SUMS

whoami : root

It does look like files are missing. Maybe sometime later today I can download the archive and check for myself.

1 Like

I had the same issues also when I downloaded the previous file .

Well, I’m getting the impression that the documentation hasn’t been updated.

When I look at the old file I had on my computer, it does contain FP3_flashall.
My assumption is that there were some significant changes for the offline install between Android 10 and Android 11.

It seems now with Android 11 it should be flash_fp3.sh instead of FP3_flashall and the docs are not updated accordingly.

1 Like

I typed sudo chmod a+x flash_fp3.sh but command doesn t work .

It’s difficult for me to understand exactly what you mean with “command doesn’t work”. Do you mean “flash_fp3.sh” doesn’t work when executed or the command sudo chmod a+x flash_fp3.sh itself doesn’t work (and I’m surprised you need it at all as in the output of the “ls” command the shell script already is executable)?

1 Like

Well, the current docs say so. But you are right, it’s not necessary.

2 Likes

After I type sudo chmod a+x flash_fp3.sh the script simply does not start.

Sorry, if I misunderstand this. But to start the script just type ./flash_fp3.sh or maybe sudo ./flash_fp3 (assuming you’re in the correct sub directory, i.e.
home/…/FairFone/FP3 OS ./FP3-REL-8901.4.A.0017.3-gms-15368f27-user-fastbootimage).

1 Like

What this command does: it marks the script named flash_fp3.sh as executable (+x) for all users (a).
Which is successful and therefore does not give any error message. It ist very common for Unix/Linux commands to be “silent” when everything worked as expected.

2 Likes

Thanks Folks ! Solved ! Script starts .

3 Likes

It seems now with Android 11 it should be flash_fp3.sh instead of FP3_flashall and the docs are not updated accordingly.

Hi Ingo, this slipped under the radar, thanks for pointing it out. It’s fixed now.

2 Likes