Camera not working since android 13

Hi
when trying to use the default camera app, i can take a picture (i press the button, the flash light on, i hear the shutter sound), but the picture does not appear in the library. sometime the picture appear after 1 or 2 minutes. often, the library buble remain completely black.

i tried:

  • resetting app cache
  • resetting app settings
  • restarting in safe mode
  • re initializing android to default state.

no luck :frowning:

using a Gport camera works fine, so it’s not a problem with the sensor.

1 Like

Camera app cache would have been my first suggestion, too.

So question: Are you using a microSD card in your device? If yes: Is it set up to hold apps, too (not just data)? I’m asking because in the past, users have had issues with saving photos when using an SD card set up as “phone storage”. Most regulars here recommend to set up an SD card as “portable storage” instead (if it is set up as portable storage, you should see the SD card symbol with an EJECT symbol next to it in the “Files” app’s side bar.

1 Like

Hi
thanks for trying to help, but…
i tried with and without SD card
my card is formated as external, and i don’t store application on it.

in the camera app, the setting is by default, so pictures are saved in the telephone, not SD.

I updated the phone this morning
i was full of hope it would fix my issue
nope.

so, my camera still work barely
almost 3 over 4 photos are not saved, and those saved, it takes 20 / 40 secondes to display it in the library
it’s like the camera try to save the file but fails, or is very slow

is there a way to check the filesystem on the phone ?
to detect a possibly faulty device ? because i also have a very slow phone since few month.

Have you tried removing the microSD card (with the phone turned off) and see if the problem persists? I say this to be sure that the problem is not related to the microSD card.

1 Like

I notice that Fairphone’s default camera app in Android 13 on the FP3 is set on HDR resp. “A HDR” (my guess is the A stands for “auto”) at the top of the camera user interface. HDR shots can take quite a while to be completed into a picture file.

Maybe you can try if deactivating HDR altogether makes a difference. I’m not saying this is acceptable, but it could help narrow down the problem.

1 Like

Yes, same result without SD card
Some pictures are saved after 15 or 20 seconds, most are not even after a long time.

1 Like

I tried all settings without success. :frowning:
It’s like the app was getting error While writing the file, but I did not found any log to check that.

I can see in your original post that you reseted app cache (and I gess also app storage). Have you tried reseting permisions? (it’s in app settings too).

I’m sorry, mine works just well, I can’t think in another think. Maybe it worth to contactsupport.

Yes i tried

i also did a factory reset.
and i tried to use the camera just after the reset: same error :frowning:

here is an example:

As you can see, i open the camera, press the capture button, we clearly see that it’s accepted as the screen flash a little, but if you check on the bottom left, the galery icon remain black.

I waited for a long time, then opened the gallery, and as you can see what’s opener is not the picture, but my last video of my dog :frowning:

(i took this video with Gcam because camera is not working)
if i do the same thing with Gcam, it’s slow as hell, but the picture is saved.

sometime, it will works for 3, 4 pictures, then it will not work again.

edit: even before taking the picture, there is a problem. the gallery icon on the bottom left remain black. sometime, i see the last picture after 15/20 seconds. sometime, it remain black indefinitly
i see that there are developer options in the camera. is there some logs i can check somewhere ?

1 Like

I can’t think of a solution to your problem. I can only recommend you to talk to support (contactsupport), in case you didn’t yet. Or maybe someone else on the forum has another idea.

I have recorded a video taking pictures with the default camera of my FP3, which works correctly (Android 13 - Update 6.A.020.0). In the video I also review the settings I have selected in the app, in case you want to check it or compare it with yours (including developer options). I have no SD installed.

I hope you solve the problem soon.

Best regards.

Thanks

the phone suddenly died this afternoon
batterie seems ok as i get 3.8v on it
but plugging an USB cable does nothing…

so…

As you opened a topic for this, to not duplicate I will close here

1 Like