Camera module doesn't work

Hello, I have an FP3 that I upgraded to FP3 + thanks to the two new photo modules. Everything was working very well. Suddenly, the photo module (rear) no longer works. Without any particular event such as a fall, contact with water, etc.
What I have done :

  • disassemble the module, clean, reassemble
  • clear the caches of photo applications
  • reset the phone to its factory configuration
  • format SD card as portable memory
  • all updates are done
    No result.
    Any idea to relaunch the photo module?
    Thank you

Welcome to our community :+1:

While you already dis- and reassembled it, let me just say that for some people the flat connector that connects the module(s) with the core module became disconnected – but on the other end, the core module end. I don’t know if you checked that, just another idea.

P.S.: I know it’s a hassle to unscrew the 13 first screws yet again, but let me say that when you put everything together, you can usually get the screen working again (and try if the cameras work again) without the 13 screws if you just make sure the plastic parts click back together – just in case you need to open it yet again. If everything’s fine, just screw the 13 screws back in at the end.


Thank you for your answer.
I opened the phone again and checked the connections to the camera module and to the main unit. Everything seems fine.
But the camera module is still not working.

1 Like

Well in that case, you should get in touch with the support.


While this idea seems widespread, it is not correct.
There are more differences in the Fairphone 3+ than just the camera modules. You don’t have a Fairphone 3+ now, you have a Fairphone 3 with upgraded camera modules.

1 Like

Yes, indeed. But the upgraded camera module worked well for almost a year.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.