Camera is not working anymore

Good day
I built a new camera into my Fairphone 3 today. But now I can’t switch from selfi mode to the rear camera.

Switching to the old camera didn’t help either.
What can be the reason?

Thx for your inputs and help

Welcome to the Fairphone community.

Can you tell us more detailed what you did and why? Was the old camera module broken and you swapped it to an identical module? Or did you upgrade from the 12MP module of the FP3 to the 48MP module of the FP3+?
Which software is running on your FP3? Which camera app do you use?


One easy first thing to check is whether using a different camera app (e.g. Open Camera) makes a difference.

If using a different app does not change anything, you might want to check if the camera module is properly connected:

Please note that the Rear Camera Module connector (the black thing bearing the empty triangle icon) can sometimes become disconnected on its other, “invisible” end, too – beneath the camera icon that you can see in Step 11.


Hallo Urs
Danke für deine Antwort. Ich habe Open Camera downgeloadet und in der Tat hat es damit funktioniert.
Nun habe ich wieder die neue Kamera eingebaut und es geht nicht mehr.
Woran kann das liegen? Falsche Kamera?

Freundlicher Gruss und vielen Dank für deine Hilfe

thx for your answer. I just updatet from 12MP to 48MP.
Software is 4a.0022.0
Camera app i used the normal one. but i tried with Open Camera. With open camera it worked again, but after changing with the new camera it doesn’t work anymore.

Hallo Urs und Co.

Ich konnte das Problem beheben. Das Kabel auf der Seite des Core-Moduls hat sich etwas gelöst und keinen Kontakt gemacht.
Jetzt klappt es bestens und die Kamera läuft.
VIelen Dank euch für die Hilfe.
Freundliche Grüsse


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.