Camera button doesn't work with non-goggle app

I’m trying as best I can to avoid using google apps, since I don’t like software that goes through my personal data… So I had to install another camera app and now it doesn’t work with the hardware camera button. Does anybody know how to fix it?

If you don’t want to use the Google Camera at all you can deactivate it in Settings > Apps > All. Then pressing the camera button should open the other app, or - if you have more than one - ask you.
You can also leave the Google Camera App activated but “clear defaults” in Settings > Apps > All. Then you’ll be asked too.

If you want to avoid Google you can also start #livingwogoogle on #software:fp-open.

1 Like

Hi and thank you for the quick response!

I wish it were that easy though, I have Open Camera, but the camera
button doesn’t seem to do nothing at all. And in the settings for the
Camera Open app there are only settings for the volume controls, the
"shutter" isn’t mentioned, and I can’t find it in the settings in the
phone for the hardware controls either…


I use Open Camera too. If I’m on the home screen I can open Open Camera by long pressing the camera button and I can take a picture then by short pressing it. I didn’t change anything in the settings.


Thanks for the hint, I hadn’t realized the long-press option before. Works also fine for me (FP OS 1.7.0 w/ Open Camera as default).


Hi Fabian,
Being a FP1 owner I don’t know anything about FP2’s camera button, but:
if you open the OpenCamera settings menu (the cogwheel button), you should find a section named “More camera controls…” There you’ll find a few options, e.g. taking a photo by tapping the screen, or by pressing the volume key. Maybe this could be a solution?
If you’re avoiding google, how did you get the OpenCamera app? Via F-Droid? Or did you download the apk file directly from someplace? If the latter case, maybe the apk file is corrupted somehow?

Hi, thanks, but it still doesn’t work, or it’s a bit confused – I had both Open Camera and Focus. With Open Camera the camera button works as shutter but not to open up the app, and with Focus it’s vice versa (the camera button opens app but doesn’t work as a shutter)…
I got Open camera from the F-droid depository.
There doesn’t seem to be any settings for the camera button in Open Camera.

What happens if you uninstall focal?

I already uninstalled Focus… Open Camera works, but I just can’t start it with the camera button. Maybe there’s some downloadable additional settings for the FP2?..

I didn’t adjust any settings (besides making Open Camera the default camera app), I just need to press the camera button some seconds (feels like > 3 secs), on releasing it Open Camera opens.

However, this only works from the homescreen / after unlocking the phone. It does not work from the lockscreen itself. There either I have to swipe the camera icon (bottom right on the lockscreen) or unlock the screen and then use the camera button.

Don’t know if that’s flaw or feature.

Ok, now it works finally! I think I just had to restart the phone… Thanks for the help! And I’m sorry if I wasted your time!

I’m using the App Snap Camera. The Camera Button works and this app has many useful settings on board. My opinion, snap camera is the best solution for FP2. I tried and bought many camera apps but this one was the best solution. The 2€ can for Snap Camera can be worth.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.