Camera App suddenly stopped working

Hello. I’ve suddenly hit a problem on my FP2 with the main Camera app just refusing to start. If I load it once via my launcher, or by double-tapping the power button, it just returns to the home screen. If I load it again, I get a message saying “Camera keeps stopping.”

Other apps seem to be able to use the camera itself.

Is it “safe” to delete cache and storage for the camera app, or would that risk deleting all my photos? Any other suggestions very welcome.

I’m on the latest release, 22.08.0-rel.0.

1 Like

It will probably erase app settings, but your photos will not be erased :+1: (have a look at the size of app cache/storage: the data will probably amount to the equivalent of less than just a single digit number of photos) Deleting camera app cache and storage is actually what most of us here would have recommended to you, too. :slight_smile:

1 Like

Thanks - helpful to have a quick sanity check on that one! I’ve tried clearing both, but it didn’t resolve after either of them, sadly. A restart doesn’t seem to help either :frowning:

I’ll try installing another camera app as a temporary workaround, but any way to get further logs which might indicate why it’s crashing?

Oops, only just noticed other apps can access your camera – so hiding my below advice :innocent:

Mechanical steps

If another app won’t access the camera(s) either, the natural next step would be unscrewing and re-screwing the camera and/or top module(s). Make sure that in the end, the screws are reasonably tight. If the camera module is a 12 MP one, the last mechanical resort would be to remove the two black sticky rings from the module (around the screw holes).

Fairphone 2 Repair - iFixit

After clearing cache and storage, did you reboot? Sometimes required to make some change take effect.

Yep - tried a couple of reboots but no good still. Weird - it worked absolutely fine until September the 27th, and then hasn’t worked from the 28th. I did delete a large amount of photos recently to save space, but can’t imagine why that would break anything. I thought I installed the new OS update before the 27th too, but can’t quite remember now.

I’ve installed Open Camera which works fine at least.

1 Like