Camera app does not load - black screen

After this week’s FP4 OS update the “stock” camera app does not finish loading. It is just a black screen for… at least 5 minutes (i lost patience after that).

The camera works fine with other apps like open camera, whatsapp, signal, etc.
Anyone got any clues?

I tried the usual: rebooting the phone, clearing the cache, clearing the cache and storage, reinstating all permissions, etc.

1 Like

It’s always helpful to indicate the precise version you’re running, even if it’s “this week’s FP4 OS update”. This is because not all phones receive a new version at the same time, and it’s also helpful in the future when re-reading a post. So could you report the value you see when you go to Settings > About phone > Build number.

If possible, could you also tell us which was the previous version that you were running on the phone, before doing the update?

I would advise you to contactsupport about this straight away, as there may be a wait in the queue.


  • does the “black screen” extend to the whole screen or do you see the app functions and just black coming from the camera itself?
  • does this happen indoors as well as outdoors?
  • have you tried disabling adaptive brightness and turning brightness up to max?


fp4 ver FP4.TP2D.C.0112.20240313
camera app v7.00.04.0007.7.0

I don’t know which version I had before. I believe before this one, it was the big camera overhaul version.

I didn’t want to slam the support button without checking in with the hive mind :wink: and it is not critical in my life, I just found it odd and wanted to leave a breadcrumb if case someone else had the same issue :slight_smile:

  • Black screen is the whole screen except for the ⨞ ◯ ⧠ android symbols.
  • yep, indoors and outdoors
  • Brightness is set to max. (double checked) and the android symbols are easy to see

This was reported for a few after the big camera update, so check the internal test menu


happy clappy hands

I did the troubleshooter thing, the wide camera failed, I opened the phone, and one of the camera connectors was disconnected. Connected it, and huzzah! :smiley:


Thank you :slight_smile: