CalyxOS (is coming to) is here for FP4!

Same here, works like a charm!

1 Like

Did you use stock FP4 Android before it? Would you say the experience is smoother? Is the battery life better? Etc.

I can just agree to the others (@SkewedZeppelin , @cosmic , @O.o , @Singulus , …) it works like charm! I never had such a “relaxing techie life” with a custom rom before. :wink:

About battery life, at least I cannot tell you, as I directly installed CalxOS when I got my FP4.

Another question:
Does anyone know if there is some new functionality that the phone is constantly vibrating when it is fully charged (like a reminder to unplug the charger or so) ?

It happened to me couple of times during the night that the phone vibrates (constantly but not very heavily) and I had to get out of the bed to check what the heck is vibrating in the other room. ^
Something new they added with the Charging Control or so?

Using 4.12.0 right now (looks like I have to update to 4.12.1 but anyway). Let me know if someone else faced the same! :wink:

Disablig haptic feedback should take care of any vibration:

Yeah sure but I don’t wanna disable any kind of vibration.
It is clearly related to the Charging Control. I also checked a different charger etc.

Everybody can try on your own.
Enable “Changing Control” and limit charging percentage to e.g. 80%

Wait until this value is reached.
Phone will constantly vibrate then, which is annoying of course.


  • CalyOS 4.12.0 - lets see of this stays or maybe already fix in a newer build
  • in: Settings > Sounds and vibration > "Charging sounds and vibration" has to be enabled → I disabled this for now, as I would like to keep the charging control enabled.

Or there may be some different reason causing this because I use charging control limited to 80% for overnight charging and I do not experience the issue you are describing even though I have “Charging sounds and vibrations” enabled.

I am on CalyxOS 4.12.1 and I think the only difference to 4.12.0 is the update to FP4.SP2J.B.086.20230807 that changes the screen’s sensitivity.

1 Like

Ah sorry, I thought you did. It’s the first thing I disable in any phone: I can’t stand vibrating things. Well, not in my pocket anyway. I incorrectly assumed what’s what you wanted to do too.

can’t reproduce over here.

Seams to be not happening anymore with 4.12.1 :man_shrugging:
So yes, @cosmic the update somehow fix this.

Still I’m wondering if it is healthy when the charging go on and on and keeps the level at 80% :thinking:
Maybe there will be further options in the future like a upper and lower limit or so.
(same like Battery Charge Limit - e.g. Battery Charge Limit | F-Droid - Free and Open Source Android App Repository - Apps provided)

1 Like

Fairphone’s hardware allows for pass-through charging, so the battery is kept at 80% without being contstanrly charged and discharged, and the phone’s being powered directly by the current from the charger.


So I think my FP3 is slowly reaching the end of it’s life. And I’ve been looking around for a replacement. So far I’ve been running LineageOS+MicroG, which works well enough. But I’d like to go for something that supports CalyxOS or GrapheneOS, so the options are pretty much a pixel or the FP4. And I’d like to support the philosophy of Fairphone, and if that means less stellar hardware and some camera jank so be it.

But all of the reports of bricking with bootloader locking has me a little spooked.
I get that realistically an evil maid attack is pretty unlikely, but I’d still like a locked bootloader for peace of mind if at all possible.
Is the bricking still a common issue currently?
I saw the “make sure to get_unlock_ability before locking bootloader” post, but if this returns 0, is there a surefire way to make it possible to lock?
A lot of people here warn of bootloader locking, but aside from this issue I can’t think of a reason why you wouldn’t want to lock an unrooted custom OS.

Any insights?
I wouldn’t want to spend a couple hundred euros for a silicon brick.

Wait for the FP5 to get CalyxOS in a few months. That’s my suggestion.

1 Like

If you don’t want the FP5, Calyx has an installation script that does everything and checks for unlock ability before locking the bootloader. It worked flawlessly for me.
I lost the unlock ability before and the enabling option in the developer settings was grayed out with IodeOS (but I think it was my fault since I booted the OS before locking the bootloader). After some weeks or updates the option was available again. I don’t know how and why. Since then I use Calyx with a locked bootloader.
So if you are careful, you will not brick it. Maybe you don’t end up with a locked bootloader.

It must be re-iterated that Verified Boot is only enforcing when the bootloader is locked.
Verified Boot explicitly does provide protection against remote attacks, not just physical ones, as it makes it harder for malware to persist across reboots or factory resets.


I keep mine unlocked, unwise though it is from a security standpoint, for one single reason: if Fairphone tanks, I’m locked out of my phone.

I really wish I could run their code generator thing locally, so I could relock my bootloader and be sure I won’t depend on a defunct company to unlock it again if I need to. But of course it would makes no sense for them to make this unlock mechanism public.

Your ability to unlock the bootloader on Calyx doesn’t depend on Fairphone’s code generator / online check, that’s a FPOS “feature”, you can just toggle the switch.


So I went ahead and got an FP4 and flashed calyxOS. The first try failed and it was briefly without and OS (Lichte paniek). Locking the bootloader during the setup resulted in a “Your device is corrupt. It can’t be trusted and wil not boot.”
Luckily I could fastboot flashing unlock, and tried again.
Second time around I got calyxOS working, when I didn’t lock the bootloader during setup.
Moreover this resulted in OEM unlocking being greyed out and fastboot flashing get_unlock_ability=0
Which is also suboptimal.
I tried flashing it and locking bootloader again, with the same results as before.

Eventually I was pointed to the /e/OS documentation:

Caution: The FP4 comes with an anti-rollback feature. Google Android anti-roll back feature is supposedly a way to ensure you are running the latest software version, including the latest security patches.

If you try installing a version of /e/OS based on a security patch that is older than the one on your device, you will brick your device. Click on Details below for detailed information

Now I’m assuming calyxOS is behind on security patches frrom FPOS, and am hoping that flashing a newer version later on will solve the error.
I’m not sure if this means I will be able to install calyx with a locked bootloader when they drop a new update, or if having a phone that’s both ethically sourced and privacy/security focused is just too much to ask.
I might just go back to LOS+MicroG.

If you updated your phone to the latest FPOS release before flashing Calyx, try the latest Beta (4.13.2).

It’ll probably move to stable any moment (been out since the 14th), but the stable is just a relabled beta and I haven’t experienced or seen any issues so you can just go ahead and install it now.

1 Like

The version you mentioned is NOW stable :).


I think I got it a bit earlier, but I assume this is why I’m am on the “Security express” - Release channel right now.