CalyxOS (is coming to) is here for FP4!

I follow your lead, Sir. Thanks for all the info on IodeOS here and thanks for making sure I am not sacrificing all the work I had to customize it to my demands just to check out CalyxOS. Highly appreciated!

1 Like

Don’t find a button for wide angle cam and 12 MP seems to be max:

2 Likes

All right, thank you.

1 Like

It’s the default AOSP camera they are using without any changes.
This cam cannot more :wink:

1 Like

You mean that the camera app by itself is only capable of 12 Megapixel and that there is no possibility to change to wide angle?
Which cam does iodé use and what works/doesn’t work? Does any of the gcam ports work with the wide angle camera and support the full resolution?

Should summarize it

Yes, as Yvonne already mentioned, it’s a topic of the API and the close source part of Fairphone cam.
iodé is using OpenCamera as default cam app with a few adjustments, but not wide angle lens.

Only /e/ has this fix in their OpenCamera fork, and I think they only could do this because of help from Fairphone.

2 Likes

@Volker , @hirnsushi
Is osmand and/or organic map working correctly? Regarding gps?
Did you get directly a gps fix? outdoor?

and indoor? without cannot seen satellites?
using the microG location providers?

What I mean, do you have directly the correct position if you start one of those two apps?

thanks :wink:

one other thing which is bothering me about calyxOS. But this is only my opinion and view…
calyxOS has “only” a firewall to prevent apps on network interface level to connect to internet and “outside world”
To prevent system from trackers, malware, etc… you have additionally to install DNS filter such as personalDNSfilter, RethinkDNS, or adAway, which are using VPN as long as the system is not rooted.
iodè has this build in in their ROM. (I know this is the non-Open-Source part, but it doesn’t hurt me).

Yes, location worked perfectly in organic maps with microG installed (have tried it indoor).

2 Likes

I would say: for my understanding, it only summarizes it to a limited extent (I’ve read it all before) because: the FP Android is based on A11, CalyxOS on A12.
So it could be that CalyxOS has found a way to work around the problems of the original Android or that the problem does not exist with A12. But since I have too little technical knowledge about the structure of Android and the nature of the problem, I just ask.

From my limited understanding of this topic the problem isn’t necessarily with any specific Android version, but rather that the FP Camera uses a proprietary API to communicate with the hardware and a lot of that isn’t exposed to the open Camera2 API.

It would be best for Fairphone to just adhere to the open standard! If custom ROMs have to fight for every camera functionality this might always be an uphill battle :roll_eyes:

6 Likes

So if I understand you correctly, the problem is in the proprietary firmware of the camera?

As far as I understand it, yes.

That firmware will obviously stay proprietary, so either Fairphone exposes more functionality to the Camera2 API or workarounds have to be found to talk to the hardware, potentially by reverse engineering how the FP Camera app communicates.
I can’t tell you how the custom ROM devs are trying to tackle this at the moment, haven’t looked at the code and I’m not a java developer :man_shrugging:

1 Like

Thanks for the explanation, that clears it up for me!

Don’t you have TWRP working for your Pix5? Backup/Restore could be a good solution to quickly go back to stock after your “little road-trip” :slight_smile:

1 Like

no TWRP
installed stock A12L manually again and setup my apps again. not that much. as said, only 2FA apps…
but thanks for the hint…

It is very quiet re installation of Calyx test system here. Do not see many experience reports on telegram for Fairphone as well.
For me it means either:
Not many Fairphoners installed it
or
Calyx runs so well that nobody reports any problems ;-

it’s just a test build… :wink:

I’m very happy with it so far, so yeah, nothing bad to report :smiley:

But I don’t use any apps that require real Google Play Services support, almost exclusively FOSS, so probably not the right person to test this…

Oh and I’m coming from a Nexus 4, so everything is an improvement :smirk:

2 Likes