CalyxOS (is coming to) is here for FP4!

So there is a little way to got until feature parity woth LineageOS or is that one also missing in LOS currently? Anyway, I’m still setting up CalyxOS as my daily driver and hope the first OTA-update wont kill me ^^. How are your experiences with OTA updates? Magisk has to be reinstalled I guess? Did you manage to achieve Safetynet checks passing?

That feature isn’t in LineageOS 19.1 either, here’s a recent reddit post asking for it.

OTA updates aren’t an issue, I’ve done all of them without any problems:

Haven’t tried anything SafetyNet related, I use nothing that would need it :man_shrugging:

I’m not sure if Calyx is the right CustomRom for you if you have a lot of customization/colors/etc. needs. ^^

I think all the custom roms have their goal/idea. Calyx is clearly described as Privacy, Security, prevent tracking, Free Software, etc. focusing
(–> About CalyxOS / CalyxOS - Wikipedia)

These goals totally fits at least to my needs (and that it works stable as the FP4 is my daily driver → I can say after some weeks using it this is the case … even CalyxOS is still not yet official)

Even though I have to admit that I also tend to bring back things working the same way as on my old phone (the FP2 same as for you afaik). :wink: The biggest loss for me up to now is the missing notification LED, but this is a Hardware problem and I cannot blame Calyx for that.

I also adjusted the font size as a first step as it felt to big for me (Settings → Display → Appearance → Font-Size → one level down from Default to Small). Apart from that I have chosen my preferred launcher some time ago ( and I think if you have one as well it will always bring back more or less the same look and feel.


Leider in einem Englisch was sich nicht in Deutsch übersetzen lässt

The same holds true for me, I found it to be unusal big but choose a lower element display size.

I confirmed that it’s possible to use an exFAT formatted SDCard, which was not possible for FP2. F2FS also doesn’t yet work. I’m using Signal backups to external SD and for files bigger than 4GiB FAT32 doesn’t work anymore.

Is anyone using OpenCamera and has some configurations hints for me :)?

Interesting. How did you do it, which SD type/vendor do you use and how did you format it (which OS, which tool?) My Sandisk SD is still not working as I would expect it some apps don’t see it of errors occur when they write to it. I also would like to reformat. (same reason btw. - big Signal backups but due to the fact that the FP4 has much more space not that urgent anymore as for the FP2. I also comment on this git issue for supporting chunked backups for Signal → introduce chunked backups by Roghetti · Pull Request #11900 · signalapp/Signal-Android · GitHub )

Open Camera: Maybe start reading this Thread :wink: : Camera & Camera2 API - missing features & bugs

I wouldn’t format the card inside the FP4, the process killed the partition table of my bigger Transcend card everytime I tried it and my smaller one always ended up as FAT32.
You can write files >4GB to a FAT32 microSD, but the consequences can be catastrophic (:de:)

Just format it on your PC, GPT partition table and exFAT should work just fine. But a SanDisk card might still find a way to fail :smirk:

Those might be the main goals of Calyx, but the fact that it’s AOSP based might make it appealing to other users as well.
Personally I want / need those privacy features, but I’m mostly using it because it feels more vanilla, and somehow different in small ways, after over a decade of LineageOS (and CyanogenMod) :slightly_smiling_face:


I used my Ubuntu 22.04 box and formated the SDCard via a MicroSDXC-adapter from Kingston as exFAT and inserted the 64 GiB card into my FP4 afterwards. It’s working nicely, and I use it mainly for backup purposes.

Edit: The card is a Samsung EVO Select 64GB microSDXC UHS-I U1 130MB/s.

Thanks for the camera link, will have a look :).

So formated just via default “Disks” application? (assuming that you have a Gnome Desktop)

Yes, that is correct.

The system does it on both laptops and both are up to date as you know. So it doesn’t work on two systems, so it can’t be because of me. It might not be on linux or any flash bar
root@t510:/home/carrabelloy/Downloads/FP4-calyxos/FP4-sp2a.220505.002# sudo ./
fastboot too old; please download the latest version at SDK Platform Tools release notes  |  Android Developers

As the message indicates, you need to update fastboot, the install script has checks to detect if the installed version is to old.

What distro / version are you running? :thinking:

That’s what I did when I used the old package, i.e. the developer package from Andriod. Or how should I update Fastboot

Depends on your distribution, if your package manager has a version new enough (CalyxOS needs at least 31.0.3), install that.
Otherwise download the SDK Platform Tools, extract them and either move them to a directory in your $PATH or just run fastboot directly from that folder ./fastboot (but you would have to modify the install script then).

What’s the output of fastboot --version on your PC currently?

1 Like

fastboot version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/fastboot

Hi there, I suspect it’s a bug in the script.

Please delete or comment the following lines in the script in try again:

if ! grep -q partition-exists $(which fastboot); then
echo “fastboot too old; please download the latest version at SDK Platform Tools release notes  |  Android Developers
exit 1

I’ve moved your reply to the Calyx thread, otherwise we’ll end up in some complicated language chaos :smirk:

Are you sure there isn’t a reason the script needs at least version 31.0.3? :thinking:
Why include it otherwise…

1 Like

From my ancient rusty German skills I thought I understood the user was sure to be using the latest version.
I actually ran into a similar issue on the windows version of flash-all.bat whereas my fastboot was the latest ones. This solved it…


I would like to repeat that again, why do you really have to update to the latest version of Fastboot now? Why does everyone have to cook their own soup? Why not take an older version that runs on all systems. This is crap. I’m fed up. Typical Americans who always do this with software. I am looking for another software for my FP4. Because I’m not doing this circus anymore. It’s getting annoying. Thank you for your help.