Calyx os on fp4, no location services inside (in interior)

Hi, i just installed calyx os on my fp4, everything works great out of the box, except for the location services :
when i try to use them inside my appartement, it does not work at all, organic maps (also tried with street complete) never stops searching. But as soon as i am outside, works perfectly !

I tried to activate every location related options (wifi discovering…) no luck for now
This issue is not a major one, but i was wondering if anyone out here experienced it (and solved it ? :crossed_fingers:)
My old pixel 3a with calyx does not have this issue.

Any idea ? :slight_smile:

Hi. Do you know MicroG? It should be in your App list and replaces Google Services and with it also location services. Maybe some options are not activated that you might want to use in addition to GPS. And is there an URL set in the upper right hand menu under “configure service URL”?

Well, GPS is the principal geo-location contributor and can only work if at least (I think) four satellites are usable, and being indoors is likely to prevent that unless you bring the device close to a window that’s not overshadowed by high-rise buildings. Other data are far less accurate and have to be built up over time and cross-referenced so I’m not surprised that you’re not getting a fix indoors with a new phone.

Try bringing it nearer a window.