Calls won't come through

I’ve just tried and it rings when the screen is active

Ok so it looks like you have a Do not disturb function. I haven’t got my phone with me but under notifications you will find options and ensure the Do not disturb is disabled.

Settings > Sound
Ensure Do not disturb is off

Settings > Apps and notifications
You will see Notifications for ** apps ~ check the phone is not in the list

If the phone is not in the list use the SEE ALL APPS and scroll down to Phone
Check Show notifications ~ they should all be on
At the bottom of that list is Modify system settings ~ check that is allowed as it may be needed to override media playing, for example

1 Like

I’ve checked and do not disturb is disabled already

Ok then better check the Notification options.

I fixed it! I’ve enabled everyone to call when in do not disturb mode (although disabled) and now it works

2 Likes

So thanks allot for the suggestions

2 Likes

Was it to do with the notification? An update on what you did would be useful to others, I had the same problem soon after getting the phone in Oct last.

It’s more important as you’ve ticked your own solution without saying what the solution was :slight_smile: So it’s not a solution for anyone else in that sense.

I’m sorry I wasn’t clear. In the notification menu I enabled everyone’s call to come through when in do not disturb mode. Although I’m not in do not disturb mode it does work

Sorry you are still not clear. :thinking:

Do you mean

Settings > Apps and Notifications > Notifications > Notifications on Lockscreen > Show alerting and silent notifications :slight_smile:

Yes that’s what I mean

1 Like

There are so many options it’s getting more difficult to find the right combination and then there’s the question of why didn’t the update respect your previous settings?

Still all sorted and lessons learnt so can’t be bad :slight_smile:

From the description, and from what I have understood, it’s
Settings→Sounds→(Advanced)→Do Not Disturb→Calls→Allow calls→From everyone
Also accessible from quick settings shade→long press on Do Not Disturb icon→Calls→Allow calls→From everyone

What I have understood is that although DND mode is not activated, he allowed everyone to call when DND was on, and it solved the problem (as if DND was really on). It seemed clear to me.
@Mathijs6 can you confirm?

Also, FYI, I have marked the answer as solution.

@Alex.A

Thanks for the guidance

I’m not sure I’ve got what you’re saying. There was no suggestion that DND was on at any point?

Yes. But although DND was off, activating this option seems to have solved the problem:

Oh! I though it was agreed it was

Settings > Apps and Notifications > Notifications > Notifications on Lockscreen > Show alerting and silent notifications

Wait a minute, I experienced the exact same problem as Mathijs6 has mentioned. Btw, try explaining this as a small business to your clients in 2021 as I need to do :roll_eyes:.
Anyway, the proposed and marked “solution” is just a “workaround” because clearly there is something wrong when we need to enable something (receive calls) that wasn’t even disabled (DND) in the first place.

Thanks @Mathijs6 for the workaround.
Fairphone team pleas keep investigating this issue.

1 Like

Sure, though the point of marking a post as solution is for people to find easily how to fix or work around an issue. Anyway, most solutions on the forum are only workarounds.

This forum is unofficial, so Fairphone might not read along here. If you want to ask them to officially investigate this problem, please #contactsupport.

3 Likes

Hi @OOG

The workaround as you call it was a settings issue that most people don’t have.

I pointed @Mathijs6 to where the problem may lay, in the notifications, and he adjusted the settings. I don’t see how this is a Fairphone problem but a user problem and as such is not a solution to a generic problem of ‘Calls won’t come through’ but a resolution to @Mathijs6 setup.

Many resolutions are as @Alex.A put it ‘workarounds’ but this doesn’t appear to be one of them, it’s a simple settings issue, the origin of which is unknown but not common. Still your post implies it is a problem for your clients.

Do you mean you have been missing calls from clients and that the changing the notifications has resolved the issue?

However if you consider this, as a workaround, unacceptable, you may, as @Alex.A indicated communicate with official support to let them know what happened. This may require to reset your phone and wipe all the apps to see if it occurs with a clean install :frowning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.