Calls are not working


I have a Fairphone 4. It behaves very strangely:

  • placing and receiving calls is not working;

  • sms is working fine;

  • mobile internet is working fine (when wifi is disabled);

  • sometimes, after you reboot the phone, calls work once again, but for a limited time and with significant variability

I can’t figure out what is happening. It used to work fine, and I’ve tested this with two SIMs but from the same carrier.

Thank you,


1 Like

Hi Costin and welcome to the community forum :slightly_smiling_face:

To me, this sounds like a problem at your carrier’s end so you need to show them. Can you reproduce it fairly easily (reboot - make a call - then stops working) ?

When did this start? Would there have been any particular event?

Lastly you do need to do a test with a SIM from a different carrier.

Hello OldRoutard,

Thank you for your response.

  • It’s not easy to reproduce this problem. As I mentioned, sometimes (1 in 10, maybe) it starts working again after booting the phone. But in general, it does not.
  • The problem started yesterday. I am unsure if it has anything to do with the fact that I’ve updated the OS since it started hours after this operation. Now, it’s the latest version of Android provided by Fairphone (v12, build number FP4.SP25.B.058.20230318). Is it possible to downgrade?
  • I will try using another carrier SIM, but it isn’t easy.


1 Like

There’s likely an adjustment that needs to be made by the carrier after talking to Fairphone. Get in touch with official FP support: click #contactsupport

Ok. I will send a request to contact support. Thank you!

2 posts were merged into an existing topic: Call quality and noise cancellation (regular calls, handsfree, Signal voice messages, Microsoft Teams video calls)

Perhaps a new SIM card will help.

Well, kind of… I’ve managed to swap three different SIM cards. The results are:

  • Digi Mobile - the primary carrier, it doesn’t work. Actually, I’ve tried two different SIM cards for this carrier, and the results are similar to what I described in the original post.

  • Orange - it works (voice, mobile internet, SMS). And I’ve used it for more than 1 hour without any problem.

  • Vodafone - it behaves in the same way as Digi Mobile: Internet (mobile, not Wi-Fi) and SMS are ok, but voice calls aren’t working or are working randomly.

At first, I assumed that this was related to the fact that I performed the OS update to Android 12, but between the update and the malfunction, more than one day passed without any problems.

I’ve also talked to technical support from the carrier (Digi Mobile). They said that the SIM is ok and from their point of view everything is fine :upside_down_face:. Which it is, since if I install the SIM on another phone, it works very well.

I don’t think that the sim slot is damaged. After all, Orange is working fine, and mobile internet and SMS services are working as they should. And the signal is full and with no variability when using mobile internet.

I’ve also contacted official FP support, as OldRoutard suggested. I’m waiting for a response.

1 Like

Just because it works in another phone does not mean it can’t be faulty. How old is the SIM and which network does Digi use, Vodafone?

If Orange works, the phone is okay.
If two different SIMs of that same carrier display the same issues, it can’t be the SIM either (it would be a hell of a coincidence they both have the exact same defect!).
Remains the carrier, and unfortunately that would also be the most difficult to fix, especially if the carrier is unhelpful (which he apparently is)… :frowning_face:


Yes, you have a point here. However, I assume (of course, I am not sure) that if the sim slot is faulty, then if you are moving the phone, it would lose connectivity due to poor mechanical connections between the sim and the sim slot pins.

All sim cards, you may say, are equally old (a few years old - 3 or 4).

Digi is using 2600 MHz TDD and 2100 MHz FDD (4G) / 2100 MHz (3G)

Orange is using 800 MHz FDD, 1800 MHz FDD and 2600 MHz TDD (4G) / 2100 MHz and 900 MHz (3G)

Vodafone does not specify on its site the networks they are using, but I found in an article that they are using 800 MHz and 1800 MHz for 4G, and I don’t know what they are using for 3G.

I assume Digi does not have its own network and is using Vodafone, Orange, Telekom or whatever it is in your country (so my provider is Simplytel and is using the O2 Telefonica network)…

As Vodafone is not working for you my assumption was Digi might use the Vodafone network. so there might be some inompatibility issue between Vodafone and Fairphone…

It used to be like that ten years ago. They were using roaming over the Vodafone network due to poor coverage. Now they have their network, which is quite extensive. However, I investigated the signal proprieties using a different phone, and it shows that the connection is established on band B20 - LTE-FDD 800 MHz, which is not officially in their portfolio. So, yes, I think that you are correct.

1 Like

Yes, I thought the same. However, it worked fine before the OS update, so that it could be related to the radio software. SMS and mobile internet are functioning ok. It’s kind of strange…

Certainly is related, the new OS does probably something slightly differently, and that specific carrier’s hardware isn’t ready for it (yet - They will fix it, eventually…).
SMS is just a fill-in, little bits of data they stick into the protocol’s transmission holes, so that would work no matter what, it’s utterly rustic. As for mobile Internet, IIRC it uses it’s own protocol, so I guess you can have it work perfectly without being able to make or receive calls.

I had a similar problem where 4g would disconnect often.
It turned out the SIM wasn’t seated properly, and I had to press it quite hard to have it ‘click’ in its place.
Maybe you could check that (again)?


Yes. It can be a poorly fitting SIM card, one slightly too wide for the slot and it will have to bend and some contacts may not meetup well.

1 Like

4g is not disconnecting. On the contrary, mobile internet is working fine. Also SMS. Voice calls are not working.

This is how the connection looks like in “stand-by” (no voice call initiated): B01-LTE, working mobile internet and SMS:

This is what it should look like when voice calls are initiated (screenshot taken using another phone, the same carrier, connected to the same cell):

However, it doesn’t change.

So, I bought an Orange SIM card. Everything works fine, as it worked with the other Orange SIM card I tried on Friday. It connects to mobile internet. This is what the connection looks like:

When voice calls are initiated, it switches to WCDMA instead of GSM:

And it works ok.
I don’t know what is happening. Before the OS update (Android 10 to 12), everything was working fine (with the Digi.Mobile SIM). Also, after the OS update, it worked for one day. Actually, I am not sure since I’ve not really used voice. And, as I mentioned before, sometimes it works, and sometimes it doesn’t.
So, it might be something with the radio software for Android 12 implementation (?!) . It works with LTE and WCDMA, but it doesn’t work with GSM.

Hello, I have the same issue. It started around 14th of April, or at least I haven’t noticed it earlier because of how rarely I make or receive calls.

Just to clarify:

  1. I cannot call (call view shows up, no signal, after a couple seconds a “mobile network is not available” message appears)
  2. I cannot receive calls (the caller gets a “the person you’re trying to reach is currently unavailable”, the call abruptly drops and then I get a “someone called you” SMS from my operator)
  3. SMS works fine
  4. mobile data works fine (although after I attempt to make a call it doesn’t work for around 3 minutes)
  5. This is all on my SIM card from T-Mobile and on another SIM card from T-Mobile from a relative; these T-Mobile SIM cards work flawlessly inside a different phone. They are also several years old. A different SIM card from Play works flawlessly in Fairphone 4
  6. I tried fiddling with VoLTE and VoWiFi settings as this coincided with my operator enabling them for me, but SIM card settings do not have these - documentation suggests that this means the operator disabled configuration of them

I contacted Fairphone support laying out everything I tried and they asked me to request a SIM card replacement from my operator. Awaiting delivery… will let you know if that helps.

1 Like