Bugs in software version 1.8

Hi there. A quick update from someone who downloaded v1.8 Kola Nut before it was pulled. This is not about the well-reported bugs during the process of updating and reinstalling, but bugs during regular use in the last couple of weeks.

  1. GPS. It seemed better at first: quicker to find my location and more precise. I don’t use it very often, but the first time after the update to 1.8 it was flawless. Subsequent times, however, the GPS was not performing that good. It’s often off by 20-50 meters. Because of this, my phone sometimes thinks I’m driving on a parallel road and it startles me with ‘take a left now! and then take a right!’ in order to get me on the correct road - on which I already am. This is very, very inconvenient.

  2. Battery drain. Overall, it is performing as good as ever. But sometimes, under 20% or 15%, it drains to 0% in a minute or two.

  3. Touch/drag. When 1.8 was announced, it was said that the tap/drag bug was finally fixed. This bug has been bugging me since forever: the phone often interprets a tap on the screen as a drag, so I have to be really precise when trying to click on something - and sometimes tap the screen 3 or more times before it finally understands the user input. After updating, I first thought that this bug was fixed. In hindsight, that doesn’t really seem to be the case. It still misinterprets too often.

  4. Signal loss/reboot. This is the most annoying bug. Since the update, I’ve had it happen a bunch of times - maybe once a week. The phone suddenly has lost signal. I don’t notice it right away, but I have missed a few calls. Trying to reset the connection, I try to engage airplane mode from the quick setting menu - but tapping it doesn’t work. Engaging airplane mode via a long hold on the on/off button does work, though. However, disengaging it does not work. The only way to fix it, is to turn the phone off and on again. (it also seems to be the case that opting for a ‘restart’ takes longer than turning it off and then turning it on by yourself, but I’m not too sure of this)

Please let me know if you have encountered the same problems.

I hope you guys at Fairphone have been working on these bugs too, not just the issues arising from trying to update to the new OS version. I’m eagerly awaiting the new 1.8 update.


Ad 2: Check out Battery Problems. It most probably is not a software bug, but an indication of bad battery quality. Hence nothing can be done about it.
Ad 3: I didn’t read that it should have been improved and I think there is still no fix (additionally read Touchs interpreted as drags.

I don’t get the first issue because I don’t use GPS. The fourth happened to me only once.

1 Like

Thank you Stefan. I added to the Battery Problems thread myself back then: Battery problems (wrong charging status / battery might be dying)

Back then, the 14%-hold bug was fixed due to an update, but a new 10%-drain bug started. After updating to 1.8 I had no problems, until a week or two ago. But it’s not a regular issue. It happens some times, but not every time.

Your link did remind me of the fact that it isn’t good to let the battery go down to 0%.

Good video on the touch/drag problem. Hope it get’s fixed. Kind of annoying, especially when browsing.

Yeah, I remember your post now. :slight_smile: Did you see mine?

I did just now, thanks. That might wel be the case. It only happened to me while I was busy with my phone. Do you have 1.8 or is this a 1.6 issue that was not solved?

Had it with both. I still don’t think that it is a software problem! [Source]

It is. Battery percentage is not so much an exact measurement as it is an estimate. A calculated estimate. If the battery is of old age, has had too many recharge cycles or too much time at a very low or a very high percentage, it should have less max energy. The battery percentage then should still be correct. Shouldn’t it?
And, of course, significant battery degradation after a year of use would be horribly bad.

  1. GPS, i experience the same problem. I’m offroad very often. Fortunately not in real life.
  2. My battery is amazing. I charge my phone one a week. I admit that I use my phone only when I need it. No games, no leasure surfing and so on. It’s both my work phone and private phone so I do use it for phone calls! And lots of other functions.
  3. ?
  4. I’m not sure, but I can recognize the problem. It happened to my some times. On the other hand, being conspirative, I think telephone companies can see to it that we loose signal every now and then. We call up again and they make more money…


I also did the Update last December, the only problem I can confirm maybe is your point 4. I have noticed crashes too and I started to Log my Bootimes after doing that. The Bootlog recorded some crashes, after very random runtimes sometimes it needs just a view minutes after a System boot to the crash, but most times it takes several days.
I have no idea about the crash reasons I thought more about the XPosed Framework as reason but maybe it is a general system process.

About the Signal loss: I had the problem maybe three or four times since the update but turning on and off the Airplane mode fixed it every time.



I made the same experience.

  1. GPS didn’t improve. When running with friends their GPS tracks (recorded on different smartphones or smartwatches) are usually far more precise than mine from the FP1U.
  2. Exactly the same behaviour. Used to be better in 1.6.
  3. Made the same experience.
  4. This is really annoying. Didn’t happen when running 1.6. Now this happens at least twice a month.

There is one more issue since the KOLA NUT update. I put it here:
5. I use some Sports apps (like kicker or sportschau app). You can configure them to be notified when something happens (e.g. when a goal is scored). I do not know what kind of technique is used but since the kola nut update this feature doesn’t work anymore.

I would really appreciate if this bugs could be fixed.


I also noticed the 4th a few times since the update. It’s annoying the FP doesn’t reconnect automatically, but waits until you get aware and type the PIN code…

Since 1.8 is no longer supported this topic is now closed. New replies are no longer allowed.